summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-06-13 14:05:21 +0200
committerLouis Sautier <sbraz@gentoo.org>2023-06-13 14:05:38 +0200
commit76f034343f5ba672554981d7e82b3ce3a097ba61 (patch)
tree0a095d4468b16971a948f1afcc525942ba238f62 /www-apps
parentdev-qt/qtwebengine: add 5.15.10_p20230505 (diff)
downloadgentoo-76f034343f5ba672554981d7e82b3ce3a097ba61.tar.gz
gentoo-76f034343f5ba672554981d7e82b3ce3a097ba61.tar.bz2
gentoo-76f034343f5ba672554981d7e82b3ce3a097ba61.zip
www-apps/klaus: add 2.0.3
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/klaus/Manifest1
-rw-r--r--www-apps/klaus/klaus-2.0.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/www-apps/klaus/Manifest b/www-apps/klaus/Manifest
index 9cde6004cc56..f18d5856d648 100644
--- a/www-apps/klaus/Manifest
+++ b/www-apps/klaus/Manifest
@@ -1 +1,2 @@
DIST klaus-2.0.2.tar.gz 43030 BLAKE2B ba3a1d07d92ab02e43a31f9e720e26bafc744c2867b8bd6cf300d6e2fdcbcb560a426e8cf55bd6d8c11d23775ae5beddb8fd3ee89c3b0f21302bb463cc2571f3 SHA512 87aa4943d4e918c7ac9c269c095b8381b9e367ed68a50fb70bd75e02ec723c379d0ceaa2da9d5b81484b4c308941283dd2fb58046ba18e0950611c51b2337edd
+DIST klaus-2.0.3.tar.gz 46961 BLAKE2B 29d84ccf829853f091f8bc944e4bf0ec119e1a2dcf67c7d82561a0924cc60634ec67580b6d9103fe33e7a4f40dc909d9dd04f1765441b9dbfd2638adad91df48 SHA512 81bb1ecd01555bb3e49b4fa482e8bfc679b9754047508201467640bab25e56e3f109339efa419f00b05d99d27138a16ab5fb7c3578792992e343653eb175fc1e
diff --git a/www-apps/klaus/klaus-2.0.3.ebuild b/www-apps/klaus/klaus-2.0.3.ebuild
new file mode 100644
index 000000000000..41b3713ceb0a
--- /dev/null
+++ b/www-apps/klaus/klaus-2.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ctags"
+
+RDEPEND="
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpauth[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ ctags? ( dev-python/python-ctags3[${PYTHON_USEDEP}] )
+"
+
+# The tests can only be run from a git repository
+# so they are not included in the source distributions
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}