summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-05 21:46:29 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-05 21:47:57 +0100
commitf11b905816fc2d2307419e1517a7df47ff13e54d (patch)
treec4194b399027f1220b18b68314df6dcf3fcf360f /www-apps/phpsysinfo
parentsys-apps/hw-probe: add 1.6.2 (diff)
downloadgentoo-f11b905816fc2d2307419e1517a7df47ff13e54d.tar.gz
gentoo-f11b905816fc2d2307419e1517a7df47ff13e54d.tar.bz2
gentoo-f11b905816fc2d2307419e1517a7df47ff13e54d.zip
www-apps/phpsysinfo: add 3.4.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'www-apps/phpsysinfo')
-rw-r--r--www-apps/phpsysinfo/Manifest1
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.4.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/Manifest b/www-apps/phpsysinfo/Manifest
index 79069e25a845..669e615fe670 100644
--- a/www-apps/phpsysinfo/Manifest
+++ b/www-apps/phpsysinfo/Manifest
@@ -1 +1,2 @@
DIST phpsysinfo-3.3.4.tar.gz 946436 BLAKE2B bdfb731ac8e60e436f915b0ac72f3c327b08dfccee0d1cedc4ddc89700c4dc76bdd73d9e37ab82fad25e096a62a9a4d31442939558ab593ba5b97520d428a6c1 SHA512 6bcbf78edfa3af441ee6768cce559635f7aed6ce0e357379a7ad1158dab21b860c82845d746f66074c84cdc92e4a21fb4710f61b69ee8cfa1e457d098d642bf2
+DIST phpsysinfo-3.4.1.tar.gz 980537 BLAKE2B f0924e2855bb682cc6a5be62d35e1a04463e3fdbad75e8f7ee43d0f9cf4ede53091d7495d68a10a3521f6eb3b8460d3458443b840aeee705d5a74fa87b3addf3 SHA512 5e8c82ba95c9f6b4d8dddfdaabbfb676a0c63913a6cd65d6b74ffbe6369830d98cc67c8192cf06c6eaefc8689d1c40b4e1917ea21a1ecd8df7977847e3ede24c
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.4.1.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.4.1.ebuild
new file mode 100644
index 000000000000..e826867ba4b9
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.4.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature webapp
+
+DESCRIPTION="A customizable PHP script that displays information about your system nicely"
+HOMEPAGE="https://rk4an.github.com/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+RDEPEND="
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore || die
+
+ mv phpsysinfo.ini{.new,} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ optfeature "showing disk temperatures." app-admin/hddtemp
+ optfeature "showing system uptime." app-misc/uptimed
+ optfeature "showing snmp statistics." net-analyzer/net-snmp
+ optfeature "showing iptables rules." net-firewall/iptables
+ optfeature "showing ipmi sensors." sys-apps/ipmitool
+ optfeature "showing ipmi sensors." sys-apps/ipmiutil
+ optfeature "showing system sensors." sys-apps/lm-sensors
+ optfeature "showing s.m.a.r.t. health." sys-apps/smartmontools
+ optfeature "showing lsi raid controller health." sys-block/megactl
+ optfeature "showing fake raid statistics." sys-fs/dmraid
+ optfeature "showing software raid statistics." sys-fs/mdadm
+ optfeature "showing quota information." sys-fs/quota
+ optfeature "showing ipmi sensors." sys-libs/freeipmi
+ optfeature "showing apc ups statistics." sys-power/apcupsd
+ optfeature "showing ups statistics." sys-power/nut
+}