summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/coppermine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/coppermine')
-rw-r--r--www-apps/coppermine/Manifest1
-rw-r--r--www-apps/coppermine/coppermine-1.5.20.ebuild41
-rw-r--r--www-apps/coppermine/files/postinstall-en.txt14
-rw-r--r--www-apps/coppermine/metadata.xml8
4 files changed, 64 insertions, 0 deletions
diff --git a/www-apps/coppermine/Manifest b/www-apps/coppermine/Manifest
new file mode 100644
index 000000000000..910d6f2e8522
--- /dev/null
+++ b/www-apps/coppermine/Manifest
@@ -0,0 +1 @@
+DIST cpg1.5.20.zip 19122378 SHA256 f5388d6fa0952f4aba8f51ae9f86c7f916c432831e02050c27d27737cececcf5 SHA512 8dd1ab52eedd8d1bd9eb95936125eaff595a66ca936857a8f21025a81a4d65194b0813b2f0b5db8d9bfab5f4ffb4442afd7c06cbae078e576bc8355c921042bf WHIRLPOOL 1c6c28a72aaa63501e3b11a794de89a5cd1b30577768e3c76f5ae97f0f56c6c743b2af1ec8a07a2fde6e745bbbf89ffe1b8b74140039e0468830bf748b1b44fe
diff --git a/www-apps/coppermine/coppermine-1.5.20.ebuild b/www-apps/coppermine/coppermine-1.5.20.ebuild
new file mode 100644
index 000000000000..4ba87574ab2a
--- /dev/null
+++ b/www-apps/coppermine/coppermine-1.5.20.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit webapp versionator
+
+DESCRIPTION="Web picture gallery written in PHP with a MySQL backend"
+HOMEPAGE="http://coppermine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/eenemeenemuu.u/cpg${PV}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/httpd-php
+ dev-lang/php[gd,mysql]"
+
+S="${WORKDIR}"/$(version_format_string 'cpg$1$2x')
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.txt README.txt
+ dohtml -r docs
+ rm -rf CHANGELOG.txt README.txt COPYING docs/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/albums/{userpics,edit}
+ webapp_serverowned "${MY_HTDOCSDIR}"/albums{,/userpics,/edit}
+ webapp_serverowned "${MY_HTDOCSDIR}"/include
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/coppermine/files/postinstall-en.txt b/www-apps/coppermine/files/postinstall-en.txt
new file mode 100644
index 000000000000..8e2ede806ddf
--- /dev/null
+++ b/www-apps/coppermine/files/postinstall-en.txt
@@ -0,0 +1,14 @@
+To complete the installation, you must
+
+1. Manually create a MySQL user and database.
+ The installer will handle the rest.
+
+Finally, point your browser to:
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/install.php
+
+==
+
+To complete an upgrade, point your browser at:
+
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/upgrade.php
diff --git a/www-apps/coppermine/metadata.xml b/www-apps/coppermine/metadata.xml
new file mode 100644
index 000000000000..276a32a3c827
--- /dev/null
+++ b/www-apps/coppermine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <upstream>
+ <remote-id type="sourceforge">eenemeenemuu.u</remote-id>
+ </upstream>
+</pkgmetadata>