summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-11-30 15:19:56 -0500
committerCraig Andrews <candrews@gentoo.org>2024-11-30 16:03:48 -0500
commit8cea8cd0fa897c785c48eede96e55245f61683f9 (patch)
tree9495968f8e1a40fd272f4e0634c35db3e9186b52 /www-apache
parentsys-apps/bat: keyword 0.24.0-r2 for ~mips (diff)
downloadgentoo-8cea8cd0fa897c785c48eede96e55245f61683f9.tar.gz
gentoo-8cea8cd0fa897c785c48eede96e55245f61683f9.tar.bz2
gentoo-8cea8cd0fa897c785c48eede96e55245f61683f9.zip
www-apache/mod_authz_unixgroup: add libbsd dep
Closes: https://bugs.gentoo.org/944565 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.2.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.2.0-r1.ebuild b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..f2a962a49040
--- /dev/null
+++ b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.2.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit apache-module
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/phokz/mod-auth-external.git"
+ inherit git-r3
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/phokz/mod-auth-external/archive/${P}.tar.gz"
+ KEYWORDS="amd64"
+ S="${WORKDIR}/mod-auth-external-${P}"
+fi
+DEPEND="dev-libs/libbsd"
+RDEPEND="dev-libs/libbsd"
+
+DESCRIPTION="An Apache2 authorization DSO using unix groups"
+HOMEPAGE="https://github.com/phokz/mod-auth-external"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+need_apache2_4
+
+DOCFILES="CHANGES INSTALL README"
+
+APXS2_ARGS="-c ${PN}.c -lbsd"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTHZ_UNIXGROUP"
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}