summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2018-12-10 08:43:26 +0000
committerMike Gilbert <floppym@gentoo.org>2018-12-30 15:31:45 -0500
commitc341df8256c345d3aff999824f8682ee624b53f9 (patch)
tree80fa5ace3836f8ff434c58a7779b69c194457c67 /virtual/python-funcsigs
parentapp-shells/zsh-5.6.2: hppa stable, bug 665278 (diff)
downloadgentoo-c341df8256c345d3aff999824f8682ee624b53f9.tar.gz
gentoo-c341df8256c345d3aff999824f8682ee624b53f9.tar.bz2
gentoo-c341df8256c345d3aff999824f8682ee624b53f9.zip
virtual/python-funcsigs: require correct USE flags of python/funcsigs
Closes: https://bugs.gentoo.org/672890 Closes: https://github.com/gentoo/gentoo/pull/10603 Signed-off-by: Alexey Sokolov <sokolov@google.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'virtual/python-funcsigs')
-rw-r--r--virtual/python-funcsigs/python-funcsigs-2.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/virtual/python-funcsigs/python-funcsigs-2.ebuild b/virtual/python-funcsigs/python-funcsigs-2.ebuild
new file mode 100644
index 000000000000..a5104ac0ae51
--- /dev/null
+++ b/virtual/python-funcsigs/python-funcsigs-2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A Virtual for Python function signatures from PEP362 (py3.6 variant)"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '>=dev-python/funcsigs-1[${PYTHON_USEDEP}]' python2_7 python3_{3,4,5} pypy{,3} )"