summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-10 11:33:30 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-10 11:54:09 +0100
commit32100e32a0b211f4ec778cb4908e45585e29a36b (patch)
treebaec9c92be2ad66cb79d6ca164918279fdda0077 /virtual/python-funcsigs
parentwww-servers/tornado: Version Bump (diff)
downloadgentoo-32100e32a0b211f4ec778cb4908e45585e29a36b.tar.gz
gentoo-32100e32a0b211f4ec778cb4908e45585e29a36b.tar.bz2
gentoo-32100e32a0b211f4ec778cb4908e45585e29a36b.zip
Sanitize virtual namespace of python packages
Rename virtual/MODULE to virtual/python-MODULE Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'virtual/python-funcsigs')
-rw-r--r--virtual/python-funcsigs/metadata.xml8
-rw-r--r--virtual/python-funcsigs/python-funcsigs-0-r1.ebuild25
2 files changed, 33 insertions, 0 deletions
diff --git a/virtual/python-funcsigs/metadata.xml b/virtual/python-funcsigs/metadata.xml
new file mode 100644
index 000000000000..6c90e346eb69
--- /dev/null
+++ b/virtual/python-funcsigs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/virtual/python-funcsigs/python-funcsigs-0-r1.ebuild b/virtual/python-funcsigs/python-funcsigs-0-r1.ebuild
new file mode 100644
index 000000000000..67548ae14cc1
--- /dev/null
+++ b/virtual/python-funcsigs/python-funcsigs-0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A Virtual for Python function signatures from PEP362"
+HOMEPAGE=""
+SRC_URI=""
+
+SLOT="0"
+LICENSE=""
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/funcsigs' python2_7 pypy pypy3 )"
+DEPEND=""