summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /virtual/mysql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'virtual/mysql')
-rw-r--r--virtual/mysql/metadata.xml8
-rw-r--r--virtual/mysql/mysql-5.5-r1.ebuild21
-rw-r--r--virtual/mysql/mysql-5.6-r2.ebuild25
-rw-r--r--virtual/mysql/mysql-5.6-r5.ebuild28
-rw-r--r--virtual/mysql/mysql-5.6-r6.ebuild41
5 files changed, 123 insertions, 0 deletions
diff --git a/virtual/mysql/metadata.xml b/virtual/mysql/metadata.xml
new file mode 100644
index 000000000000..0ea2af646750
--- /dev/null
+++ b/virtual/mysql/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mysql</herd>
+ <use>
+ <flag name='embedded'>Build embedded server (libmysqld)</flag>
+ </use>
+</pkgmetadata>
diff --git a/virtual/mysql/mysql-5.5-r1.ebuild b/virtual/mysql/mysql-5.5-r1.ebuild
new file mode 100644
index 000000000000..84019bcc2479
--- /dev/null
+++ b/virtual/mysql/mysql-5.5-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Virtual for MySQL client or database"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="embedded minimal static static-libs"
+
+DEPEND=""
+RDEPEND="|| (
+ =dev-db/mariadb-${PV}*[embedded=,minimal=,static=,static-libs=]
+ =dev-db/mysql-${PV}*[embedded=,minimal=,static=,static-libs=]
+ =dev-db/mysql-cluster-7.2*[embedded=,minimal=,static=,static-libs=]
+)"
diff --git a/virtual/mysql/mysql-5.6-r2.ebuild b/virtual/mysql/mysql-5.6-r2.ebuild
new file mode 100644
index 000000000000..2bc383dad19b
--- /dev/null
+++ b/virtual/mysql/mysql-5.6-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for MySQL client or database"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0/18"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="embedded minimal static static-libs"
+
+DEPEND=""
+RDEPEND="|| (
+ =dev-db/mariadb-10.0*[embedded=,minimal=,static=,static-libs=,${MULTILIB_USEDEP}]
+ =dev-db/mysql-${PV}*[embedded=,minimal=,static=,static-libs=,${MULTILIB_USEDEP}]
+ =dev-db/percona-server-${PV}*[embedded=,minimal=,static=,static-libs=,${MULTILIB_USEDEP}]
+ =dev-db/mariadb-galera-10.0*[embedded=,minimal=,static=,static-libs=,${MULTILIB_USEDEP}]
+ =dev-db/mysql-cluster-7.3*[embedded=,minimal=,static=,static-libs=,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/mysql/mysql-5.6-r5.ebuild b/virtual/mysql/mysql-5.6-r5.ebuild
new file mode 100644
index 000000000000..bf7ac39ad9a3
--- /dev/null
+++ b/virtual/mysql/mysql-5.6-r5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for MySQL database server"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0/18"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="embedded static static-libs"
+
+DEPEND=""
+RDEPEND="
+ virtual/libmysqlclient[static-libs?,${MULTILIB_USEDEP}]
+ || (
+ =dev-db/mariadb-10.1*[embedded=,static=]
+ =dev-db/mariadb-10.0*[embedded=,static=]
+ =dev-db/mysql-${PV}*[embedded=,static=]
+ =dev-db/percona-server-${PV}*[embedded=,static=]
+ =dev-db/mariadb-galera-10.0*[embedded=,static=]
+ =dev-db/mysql-cluster-7.3*[embedded=,static=]
+ )"
diff --git a/virtual/mysql/mysql-5.6-r6.ebuild b/virtual/mysql/mysql-5.6-r6.ebuild
new file mode 100644
index 000000000000..f3ae2ce143b6
--- /dev/null
+++ b/virtual/mysql/mysql-5.6-r6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for MySQL database server"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0/18"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="embedded static static-libs"
+
+DEPEND=""
+RDEPEND="
+ virtual/libmysqlclient[static-libs?,${MULTILIB_USEDEP}]
+ embedded? (
+ || (
+ =dev-db/mariadb-10.1*[client-libs(+),embedded,static=]
+ =dev-db/mariadb-10.0*[client-libs(+),embedded,static=]
+ =dev-db/mysql-${PV}*[client-libs(+),embedded,static=]
+ =dev-db/percona-server-${PV}*[client-libs(+),embedded,static=]
+ =dev-db/mariadb-galera-10.0*[client-libs(+),embedded,static=]
+ =dev-db/mysql-cluster-7.3*[client-libs(+),embedded,static=]
+ )
+ )
+ !embedded? (
+ || (
+ =dev-db/mariadb-10.1*[-embedded,static=]
+ =dev-db/mariadb-10.0*[-embedded,static=]
+ =dev-db/mysql-${PV}*[-embedded,static=]
+ =dev-db/percona-server-${PV}*[-embedded,static=]
+ =dev-db/mariadb-galera-10.0*[-embedded,static=]
+ =dev-db/mysql-cluster-7.3*[-embedded,static=]
+ )
+ )
+"