summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-power/thermald
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-power/thermald')
-rw-r--r--sys-power/thermald/Manifest2
-rw-r--r--sys-power/thermald/files/thermald19
-rw-r--r--sys-power/thermald/files/thermald-1.4.2-terminate-r1.patch65
-rw-r--r--sys-power/thermald/metadata.xml16
-rw-r--r--sys-power/thermald/thermald-1.3.ebuild41
-rw-r--r--sys-power/thermald/thermald-1.4.2-r1.ebuild45
6 files changed, 188 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
new file mode 100644
index 000000000000..0b96ef6ccb99
--- /dev/null
+++ b/sys-power/thermald/Manifest
@@ -0,0 +1,2 @@
+DIST thermald-1.3.tar.gz 77733 SHA256 c85c2e3400456302ee754a747e17a99871e3ddf3f0f82273de9ff6935d893af2 SHA512 6f2087de52d0f8614de1002701efba748fef114ac2161c0fe3325d545da91386f89eab4c1e218aff4acc099351acd6db747cc401444db7283961df450d94a4e4 WHIRLPOOL bc2b772bea1a6fa46e2dbbbd91217f534c9a3be420de850ab06163ae9a36cd60e6d95862167e7e242110916946f265e9214738ea4c972c6c6b99c8e0be9aad3b
+DIST thermald-1.4.2.tar.gz 89080 SHA256 4be5e1105f8b24af17d19357eda97b6edd3d74284c3ee762060d487158997f8b SHA512 373620679df7db242770ae2b5c6e2b9015cfb480539889c43b8f20f52faa139ea307985c8f7369daf14c41d987f7c5af4baecc9dd460ef63556ac982eb4bcd47 WHIRLPOOL 6abde17fc60f30dda58935663084e53cbc26ba8b59bc058b3b6f8fc03af538d6f2e363d578fcbbfb38a02bf3cda0856abcb361fb63fd2e5ce0bc2c63a4d42484
diff --git a/sys-power/thermald/files/thermald b/sys-power/thermald/files/thermald
new file mode 100644
index 000000000000..73643a27a686
--- /dev/null
+++ b/sys-power/thermald/files/thermald
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+
+depend() {
+ need dbus
+ after logger
+}
+
+start() {
+ ebegin "Starting thermald"
+
+ start-stop-daemon --start --quiet --name thermald --exec /usr/sbin/thermald -- --dbus-enable
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping thermald"
+ /usr/bin/dbus-send --system --dest=org.freedesktop.thermald /org/freedesktop/thermald org.freedesktop.thermald.Terminate
+ eend $?
+}
diff --git a/sys-power/thermald/files/thermald-1.4.2-terminate-r1.patch b/sys-power/thermald/files/thermald-1.4.2-terminate-r1.patch
new file mode 100644
index 000000000000..96ba91ffe5ec
--- /dev/null
+++ b/sys-power/thermald/files/thermald-1.4.2-terminate-r1.patch
@@ -0,0 +1,65 @@
+commit 14bf458675a735975c6b9bf7394682e93398a8e0
+Author: Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>
+Date: Tue Jul 14 17:46:45 2015 -0700
+
+ Fix regression in exit via dbus message
+
+ Terminate via dbus terminate message is broken. Fixed this.
+ Thanks to Yixun Lan <yixun.lan@gmail.com> for finding this.
+
+diff --git a/src/main.cpp b/src/main.cpp
+index 2cf4864..d692cf3 100644
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -50,7 +50,7 @@
+ #define TD_DIST_VERSION PACKAGE_VERSION
+ #endif
+
+-extern int thd_dbus_server_init();
++extern int thd_dbus_server_init(void (*exit_handler)(int));
+
+ // Default log level
+ static int thd_log_level = G_LOG_LEVEL_ERROR | G_LOG_LEVEL_CRITICAL
+@@ -263,7 +263,7 @@ int main(int argc, char *argv[]) {
+ }
+
+ if (dbus_enable)
+- thd_dbus_server_init();
++ thd_dbus_server_init(sig_int_handler);
+
+ if (!no_daemon) {
+ printf("Ready to serve requests: Daemonizing.. %d\n", thd_daemonize);
+diff --git a/src/thd_dbus_interface.cpp b/src/thd_dbus_interface.cpp
+index 021bce2..7926101 100644
+--- a/src/thd_dbus_interface.cpp
++++ b/src/thd_dbus_interface.cpp
+@@ -187,8 +187,12 @@ gboolean thd_dbus_interface_get_current_preference(PrefObject *obj,
+ return TRUE;
+ }
+
++void (*thd_dbus_exit_callback)(int);
+ gboolean thd_dbus_interface_terminate(PrefObject *obj, GError **error) {
+ thd_engine->thd_engine_terminate();
++ if (thd_dbus_exit_callback)
++ thd_dbus_exit_callback(0);
++
+ return TRUE;
+ }
+
+@@ -561,13 +565,15 @@ gboolean thd_dbus_interface_get_sensor_temperature(PrefObject *obj, int index,
+ }
+
+ // Setup dbus server
+-int thd_dbus_server_init() {
++int thd_dbus_server_init(void (*exit_handler)(int)) {
+ DBusGConnection *bus;
+ DBusGProxy *bus_proxy;
+ GError *error = NULL;
+ guint result;
+ PrefObject *value_obj;
+
++ thd_dbus_exit_callback = exit_handler;
++
+ bus = dbus_g_bus_get(DBUS_BUS_SYSTEM, &error);
+ if (error != NULL) {
+ thd_log_error("Couldn't connect to session bus: %s:\n", error->message);
diff --git a/sys-power/thermald/metadata.xml b/sys-power/thermald/metadata.xml
new file mode 100644
index 000000000000..9c025f0fed98
--- /dev/null
+++ b/sys-power/thermald/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <longdescription lang="en">
+Thermald is a Linux user mode daemon to system developers, reducing time to market with
+controlled thermal management using P-states, T-states, and the Intel power clamp driver.
+The Thermal Daemon uses the existing Linux kernel infrastructure and can be easily enhanced
+</longdescription>
+ <upstream>
+ <remote-id type="github">01org/thermal_daemon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-power/thermald/thermald-1.3.ebuild b/sys-power/thermald/thermald-1.3.ebuild
new file mode 100644
index 000000000000..de4ce55140e2
--- /dev/null
+++ b/sys-power/thermald/thermald-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon"
+SRC_URI="https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+S=${WORKDIR}/thermal_daemon-${PV}
+
+CDEPEND="dev-libs/dbus-glib
+ dev-libs/libxml2"
+DEPEND="${CDEPEND}
+ sys-apps/sed"
+RDEPEND="${CDEPEND}"
+
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemdsystemunitdir=$(systemd_get_unitdir)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ rm -rf "${D}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}
diff --git a/sys-power/thermald/thermald-1.4.2-r1.ebuild b/sys-power/thermald/thermald-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..c7e6e28b5cbc
--- /dev/null
+++ b/sys-power/thermald/thermald-1.4.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon"
+SRC_URI="https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+S=${WORKDIR}/thermal_daemon-${PV}
+
+CDEPEND="dev-libs/dbus-glib
+ dev-libs/libxml2"
+DEPEND="${CDEPEND}
+ sys-apps/sed"
+RDEPEND="${CDEPEND}"
+
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+PATCHES=(
+ "${FILESDIR}/${P}-terminate-r1.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemdsystemunitdir=$(systemd_get_unitdir)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ rm -rf "${D}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}