summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-05-14 17:19:26 -0400
committerMike Pagano <mpagano@gentoo.org>2023-05-14 17:19:26 -0400
commitef4dc751f7588b52736e0dd65d4b50eb4a304ce9 (patch)
tree08c3f3e8be2cadd08bb83343e54c9d84136a14c6 /sys-kernel
parentdev-util/nvidia-cuda-toolkit: add 12.1.1 (diff)
downloadgentoo-ef4dc751f7588b52736e0dd65d4b50eb4a304ce9.tar.gz
gentoo-ef4dc751f7588b52736e0dd65d4b50eb4a304ce9.tar.bz2
gentoo-ef4dc751f7588b52736e0dd65d4b50eb4a304ce9.zip
sys-kernel/git-sources: add 6.4_rc2
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.4_rc2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index a57bb02872a2..aaa99fc6a002 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-6.2.tar.xz 136430892 BLAKE2B 05b63254734ea685db437cb1c00a6da63eee74d7e99f4ed2d074aaa01ac4487813ab297d337a6855cdbcbb33346b631c4256ee3b06191adfb1be3615a56bdd6d SHA512 a01bee0b968b95183934fe3504516be7ef5811944a061f5aed05ecebaa27b5eb64e33232fd0a8dd622b3c8743bfe462ef7e464d381734d111a0ad6a6d9f66ddd
DIST patch-6.4-rc1.patch 150354035 BLAKE2B a2f069cd47ad350fe811cf8abe2094afd8a107f7dec1eb978ccdecbd25e2beff27dafef569617d333facbd68c23be149719ac474c7bd1526dbd36b05424f4725 SHA512 eb31cb141d8ce6ffd0bdfc6b0a27e1e8bfa5bfe43e150e35d097afb3d8fca9bae811a85da337af8b5eceaac417d2cf19728e2f35125500b03fea03c86a4eeb9a
+DIST patch-6.4-rc2.patch 150656723 BLAKE2B 624d3779fac3e586aa6609d1714f59a5c61d9b8c2ced2afaf1700d3118b8b3c8cf8a4c878b2005a72d4ef456df86412334b5390ffd3e6d4bdfa4e8cd976ba0e2 SHA512 dcd1df2705c022d46ace14f80bb163a529f15e46251120c8e5c20aaf6fbbd0a97d45170ac4995ca96fa2b8adb7016ea24b0137cfe8914e1ea8b0d8c94c890413
diff --git a/sys-kernel/git-sources/git-sources-6.4_rc2.ebuild b/sys-kernel/git-sources/git-sources-6.4_rc2.ebuild
new file mode 100644
index 000000000000..ae9a3401cdd2
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.4_rc2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.2"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}