summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-15 21:25:18 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-15 21:30:24 +0100
commitad8816953631c6b3eda9ba1a5f1e2b5e70a50d30 (patch)
tree25f86fa88f5678b75d68215aa298ff2458b4f2ef /sys-fs
parentmedia-plugins/vdr-extb: QA missing BDEPENDs fixed (diff)
downloadgentoo-ad8816953631c6b3eda9ba1a5f1e2b5e70a50d30.tar.gz
gentoo-ad8816953631c6b3eda9ba1a5f1e2b5e70a50d30.tar.bz2
gentoo-ad8816953631c6b3eda9ba1a5f1e2b5e70a50d30.zip
sys-fs/mtd-utils: Drop unmaintained -9999*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtd-utils/mtd-utils-99999999.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sys-fs/mtd-utils/mtd-utils-99999999.ebuild b/sys-fs/mtd-utils/mtd-utils-99999999.ebuild
deleted file mode 100644
index 8354dce126cd..000000000000
--- a/sys-fs/mtd-utils/mtd-utils-99999999.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils vcs-snapshot
-
-if [[ ${PV} == "99999999" ]] ; then
- EGIT_REPO_URI="git://git.infradead.org/mtd-utils.git"
-
- inherit git-2
- SRC_URI=""
- #KEYWORDS=""
-else
- if [[ ${PV} == *.*.* ]] ; then
- MY_PV="${PV}-*"
- SRC_URI="http://git.infradead.org/mtd-utils.git/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
- else
- MY_PV="${PV}-02ae0aac87576d07202a62d11294ea55b56f450b"
- SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.xz"
- fi
- KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="MTD userspace tools (NFTL, JFFS2, NAND, FTL, UBI)"
-HOMEPAGE="http://git.infradead.org/?p=mtd-utils.git;a=summary"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="xattr"
-
-# We need libuuid
-RDEPEND="!sys-fs/mtd
- dev-libs/lzo
- sys-libs/zlib
- >=sys-apps/util-linux-2.16"
-# ACL is only required for the <sys/acl.h> header file to build mkfs.jffs2
-# And ACL brings in Attr as well.
-DEPEND="${RDEPEND}
- xattr? ( sys-apps/acl )"
-
-makeopts() {
- # These affect build output, so keep it common between compile & install.
- echo CROSS=${CHOST}- V=1
- use xattr || echo WITHOUT_XATTR=1
-}
-
-src_compile() {
- tc-export AR CC RANLIB
- local compileopts=(
- AR="${AR}" CC="${CC}" RANLIB="${RANLIB}"
- )
- emake $(makeopts) "${compileopts[@]}"
-}
-
-src_install() {
- emake $(makeopts) install DESTDIR="${ED}"
- dodoc *.txt
- newdoc ubifs-utils/mkfs.ubifs/README README.mkfs.ubifs
- # TODO: check ubi-utils for docs+scripts
-}