summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-09 02:24:34 +0100
committerSam James <sam@gentoo.org>2024-05-09 02:29:43 +0100
commit123d0c034e6dea5e23dfeedbbaa1751a85793a60 (patch)
treec210c73bba1a63f34b72c1d0821da90991e46381 /sys-fs
parentsys-fs/progsreiserfs: Fix error call to undeclared function _getopt_internal (diff)
downloadgentoo-123d0c034e6dea5e23dfeedbbaa1751a85793a60.tar.gz
gentoo-123d0c034e6dea5e23dfeedbbaa1751a85793a60.tar.bz2
gentoo-123d0c034e6dea5e23dfeedbbaa1751a85793a60.zip
sys-fs/progsreiserfs: fix modern C issues in configure (sort of)
Not autoreconfing because it doesn't work w/ modern autoconf and the alternative here, rather than spending more time on it, is really to last-rite. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/progsreiserfs/files/progsreiserfs-0.3.1_rc8-c99-configure.patch93
-rw-r--r--sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8-r1.ebuild3
2 files changed, 95 insertions, 1 deletions
diff --git a/sys-fs/progsreiserfs/files/progsreiserfs-0.3.1_rc8-c99-configure.patch b/sys-fs/progsreiserfs/files/progsreiserfs-0.3.1_rc8-c99-configure.patch
new file mode 100644
index 000000000000..23fec252657b
--- /dev/null
+++ b/sys-fs/progsreiserfs/files/progsreiserfs-0.3.1_rc8-c99-configure.patch
@@ -0,0 +1,93 @@
+configure-only as cannot regenerate with new autotools :(
+--- a/configure
++++ b/configure
+@@ -7486,6 +7486,7 @@ else
+ #line 7486 "configure"
+ #include "confdefs.h"
+ #include <ctype.h>
++#include <stdlib.h>
+ #if ((' ' & 0x0FF) == 0x020)
+ # define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
+ # define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
+@@ -9698,6 +9699,7 @@ else
+ #line 9698 "configure"
+ #include "confdefs.h"
+ #include <ctype.h>
++#include <stdlib.h>
+ #if ((' ' & 0x0FF) == 0x020)
+ # define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
+ # define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
+--- a/configure
++++ b/configure
+@@ -2279,6 +2279,7 @@ rm -f conftest.$ac_objext conftest.$ac_ext
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 2280 "configure"
+ #include "confdefs.h"
++#include <stdlib.h>
+ $ac_declaration
+ int
+ main ()
+@@ -3088,6 +3089,7 @@ else
+ #include "confdefs.h"
+
+ #include <stdio.h>
++ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+
+@@ -6541,6 +6543,7 @@ else
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #ifdef RTLD_GLOBAL
+ # define LT_DLGLOBAL RTLD_GLOBAL
+@@ -6638,6 +6641,7 @@ else
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #ifdef RTLD_GLOBAL
+ # define LT_DLGLOBAL RTLD_GLOBAL
+@@ -8165,6 +8169,7 @@ else
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 8165 "configure"
+ #include "confdefs.h"
++#include <stdlib.h>
+ int
+ find_stack_direction ()
+ {
+@@ -8368,6 +8373,7 @@ $ac_includes_default
+
+ #include <fcntl.h>
+ #include <sys/mman.h>
++#include <stdlib.h>
+
+ #if !STDC_HEADERS && !HAVE_STDLIB_H
+ char *malloc ();
+@@ -9957,6 +9963,7 @@ else
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 9956 "configure"
+ #include "confdefs.h"
++#include <stdlib.h>
+ int
+ main ()
+ {
+@@ -10438,6 +10445,7 @@ else
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 10437 "configure"
+ #include "confdefs.h"
++#include <stdlib.h>
+ int
+ find_stack_direction ()
+ {
+@@ -10745,6 +10753,7 @@ $ac_includes_default
+
+ #include <fcntl.h>
+ #include <sys/mman.h>
++#include <stdlib.h>
+
+ #if !STDC_HEADERS && !HAVE_STDLIB_H
+ char *malloc ();
diff --git a/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8-r1.ebuild b/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8-r1.ebuild
index e7fe27e0eefc..7032c07d8a37 100644
--- a/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8-r1.ebuild
+++ b/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,6 +28,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${P}-autotools.patch
"${FILESDIR}"/${PN}-0.3.1_rc8-musl-getopt_internal-fix.patch
+ "${FILESDIR}"/${PN}-0.3.1_rc8-c99-configure.patch
)
src_prepare() {