summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-06 09:22:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-06 16:33:57 +0100
commit9ce0c0590b2ec32c884d831f97ba92fa5772f7f6 (patch)
treec7ca11dee13a03003b2d3d736356b3ccb92a4784 /sys-devel/llvm
parentapp-backup/btrbk: 0.32.0 version bump (diff)
downloadgentoo-9ce0c0590b2ec32c884d831f97ba92fa5772f7f6.tar.gz
gentoo-9ce0c0590b2ec32c884d831f97ba92fa5772f7f6.tar.bz2
gentoo-9ce0c0590b2ec32c884d831f97ba92fa5772f7f6.zip
sys-devel/llvm: Add a version check to the live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-14.0.0.9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-14.0.0.9999.ebuild b/sys-devel/llvm/llvm-14.0.0.9999.ebuild
index f89b54bbb6c4..de916051b792 100644
--- a/sys-devel/llvm/llvm-14.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-14.0.0.9999.ebuild
@@ -437,6 +437,9 @@ multilib_src_configure() {
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
cmake_src_configure
+ grep -q -E "^CMAKE_PROJECT_VERSION_MAJOR(:.*)?=$(ver_cut 1)$" \
+ CMakeCache.txt ||
+ die "Incorrect version, did you update _LLVM_MASTER_MAJOR?"
multilib_is_native_abi && check_distribution_components
}