summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 08:42:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 08:44:06 +0100
commitc3896a7a881f52a0ff7a6bd7f1d89e7a2523dea1 (patch)
tree6bd7d5eff497b75b5cf0589049357671db7b8e90 /sys-devel/llvm-common/llvm-common-17.0.6.ebuild
parentdev-python/mypy: Remove old (diff)
downloadgentoo-c3896a7a881f52a0ff7a6bd7f1d89e7a2523dea1.tar.gz
gentoo-c3896a7a881f52a0ff7a6bd7f1d89e7a2523dea1.tar.bz2
gentoo-c3896a7a881f52a0ff7a6bd7f1d89e7a2523dea1.zip
sys-devel/llvm-common: Bump to 17.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-17.0.6.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-17.0.6.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-17.0.6.ebuild b/sys-devel/llvm-common/llvm-common-17.0.6.ebuild
new file mode 100644
index 000000000000..b90c15d2e3e5
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-17.0.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="emacs"
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+BDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+
+LLVM_COMPONENTS=( llvm/utils )
+llvm.org_set_globals
+
+SITEFILE="50llvm-gentoo.el"
+BYTECOMPFLAGS="-L emacs"
+
+src_compile() {
+ default
+
+ use emacs && elisp-compile emacs/*.el
+}
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/*/
+ # some users may find it useful
+ newdoc vim/README README.vim
+ dodoc vim/vimrc
+
+ if use emacs ; then
+ elisp-install llvm emacs/*.{el,elc}
+ elisp-make-site-file "${SITEFILE}" llvm
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}