summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2023-06-15 07:49:53 +0000
committerSam James <sam@gentoo.org>2023-06-15 22:39:46 +0100
commitd121dc032b666f9602fd6b1b59c897aac91f6ffc (patch)
tree405360e94ca3da0f7ca7154cc0e6fd5d48978105 /sys-cluster
parentapp-admin/calamares: fix systemd-boot dep deux (diff)
downloadgentoo-d121dc032b666f9602fd6b1b59c897aac91f6ffc.tar.gz
gentoo-d121dc032b666f9602fd6b1b59c897aac91f6ffc.tar.bz2
gentoo-d121dc032b666f9602fd6b1b59c897aac91f6ffc.zip
sys-cluster/keepalived: add 2.2.8
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/keepalived/Manifest1
-rw-r--r--sys-cluster/keepalived/keepalived-2.2.8.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/sys-cluster/keepalived/Manifest b/sys-cluster/keepalived/Manifest
index 85b7125c82d9..8a884c8cbe84 100644
--- a/sys-cluster/keepalived/Manifest
+++ b/sys-cluster/keepalived/Manifest
@@ -1,2 +1,3 @@
DIST keepalived-2.2.7.tar.gz 1180180 BLAKE2B 62c4534eb1eebeac596b628a1fa5fb4069498d532fdeff0dc51afbc71e90125bff7fcffb897da3fd34765c64f43d7b04dcf184169b1bc2cf33413e109f9f5cdc SHA512 9869437fe6f0c10590b13088002b53474a51102da9838a6575d835d006c4871b61324ab80e0e81e0a23d0124e6f033cfc7114749e87b8f736408f3f0bedb3968
DIST keepalived-2.2.7_p20221209.tar.gz 959087 BLAKE2B 2c8a46874ddac414a6d6f7bc1646d90dd9afc813ffcdd5990d1a220171e77c1e17a97c0549c2223eb2401b60870b7d98139106345079033c2f2875d158024b2a SHA512 519837fd463e69bc2eb8415fa8d5e5bd92cda1d0e3e80a0725a38285901b59fa8ba9e0d6852dbbdddf4bb72398286b4fa2779a6c341245b6322c4bef8dce37d6
+DIST keepalived-2.2.8.tar.gz 1202602 BLAKE2B 3d8d738a0c4e6f00ea8dc3603813d21e52e259d301872f2db16c3373c3a034bedcf3f02e19d1b50855d90bbfece863e710d75a67e2d6dd057dfe451608a73fcb SHA512 dc0ab5b0ef8911a7859422eccc2771a40e942236c855a628158ed748eb5f7dc4b6f4850e9c3057e81fd9d2daa640ab51fb1d7af12748a613280a217b333eb06b
diff --git a/sys-cluster/keepalived/keepalived-2.2.8.ebuild b/sys-cluster/keepalived/keepalived-2.2.8.ebuild
new file mode 100644
index 000000000000..ca5547748e72
--- /dev/null
+++ b/sys-cluster/keepalived/keepalived-2.2.8.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="A strong & robust keepalive facility to the Linux Virtual Server project"
+HOMEPAGE="https://www.keepalived.org/"
+SRC_URI="https://www.keepalived.org/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="+bfd dbus json regex snmp systemd"
+
+RDEPEND="
+ dev-libs/libnl:=
+ dev-libs/openssl:=
+ dev-libs/popt
+ net-libs/libnfnetlink
+ sys-apps/iproute2
+ regex? ( >=dev-libs/libpcre2-8:= )
+ dbus? (
+ sys-apps/dbus
+ dev-libs/glib:2
+ )
+ json? ( dev-libs/json-c:= )
+ snmp? ( net-analyzer/net-snmp:= )
+ systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-4.4"
+
+DOCS=(
+ README CONTRIBUTORS INSTALL ChangeLog AUTHOR TODO
+ doc/keepalived.conf.SYNOPSIS doc/NOTE_vrrp_vmac.txt
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # keepalived has support to dynamically use some libraries instead of
+ # linking them:
+ #--enable-dynamic-linking \
+ #--enable-libiptc-dynamic \
+ #--enable-libnl-dynamic \
+ #--enable-libxtables-dynamic \
+ econf \
+ --with-init="$(usex systemd systemd custom)" \
+ --with-kernel-dir="${ESYSROOT}"/usr \
+ --enable-vrrp \
+ $(use_enable bfd) \
+ $(use_enable dbus) \
+ $(use_enable json) \
+ $(use_enable regex) \
+ $(use_enable snmp) \
+ $(use_enable snmp snmp-rfc) \
+ $(use_enable systemd)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/keepalived.init-r1 keepalived
+ newconfd "${FILESDIR}"/keepalived.confd-r1 keepalived
+
+ systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
+
+ use snmp && dodoc doc/*MIB.txt
+
+ # This was badly named by upstream, it's more HOWTO than anything else.
+ newdoc INSTALL INSTALL+HOWTO
+
+ # Clean up sysvinit files
+ rm -rv "${ED}"/etc/sysconfig || die
+}