summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-02-09 13:01:42 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-02-09 13:01:42 +0100
commitaa51027e25cc50ee82f006965290717379f9689b (patch)
treedd01b763690b5023c3fb8546674745bad3bee73b /sys-block
parentsys-fs/mount-zip: remove mount-zip 1.0.10 (diff)
downloadgentoo-aa51027e25cc50ee82f006965290717379f9689b.tar.gz
gentoo-aa51027e25cc50ee82f006965290717379f9689b.tar.bz2
gentoo-aa51027e25cc50ee82f006965290717379f9689b.zip
sys-block/mmc-utils: new package, add 0_p20231010
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/mmc-utils/Manifest1
-rw-r--r--sys-block/mmc-utils/metadata.xml8
-rw-r--r--sys-block/mmc-utils/mmc-utils-0_p20231010.ebuild35
3 files changed, 44 insertions, 0 deletions
diff --git a/sys-block/mmc-utils/Manifest b/sys-block/mmc-utils/Manifest
new file mode 100644
index 000000000000..916d4e4929d7
--- /dev/null
+++ b/sys-block/mmc-utils/Manifest
@@ -0,0 +1 @@
+DIST mmc-utils-0_p20231010.tar.gz 51083 BLAKE2B efa8bbae62ccc20ee4085c6b372ce3a35d41cf2aba12918d74d2edb0f779e7174250358d426a756075cf6dd93009b366dfb373a54bc0eb13441c4ee2e579a26f SHA512 c6ee6af49556261f1bee12580025452fa180f0bd913fac90847d86ffc5100f34905a0b0467707601a3638bfad6f3f4fca41df0cd59c7e3507981f991ede6ac10
diff --git a/sys-block/mmc-utils/metadata.xml b/sys-block/mmc-utils/metadata.xml
new file mode 100644
index 000000000000..ed50c9a25b6b
--- /dev/null
+++ b/sys-block/mmc-utils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>flow@gentoo.org</email>
+ <name>Florian Schmaus</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-block/mmc-utils/mmc-utils-0_p20231010.ebuild b/sys-block/mmc-utils/mmc-utils-0_p20231010.ebuild
new file mode 100644
index 000000000000..080ccdfd90b2
--- /dev/null
+++ b/sys-block/mmc-utils/mmc-utils-0_p20231010.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Userspace tools for MMC/SD devices"
+HOMEPAGE="https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git/"
+
+MY_COMMIT="b5ca140312d279ad2f22068fd72a6230eea13436"
+
+SRC_URI="https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git/snapshot/mmc-utils-${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror //' Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin mmc
+ dodoc README
+ doman man/mmc.1
+}