summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2021-08-25 00:41:26 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-08-25 09:52:33 +0200
commitd5806bdf4686f5af5f9f7b06741578c3e40be456 (patch)
tree5493744ce11e91a89f1a13cd87d4222114c5e970 /sys-apps
parentapp-admin/monit: Added myself to metadata (diff)
downloadgentoo-d5806bdf4686f5af5f9f7b06741578c3e40be456.tar.gz
gentoo-d5806bdf4686f5af5f9f7b06741578c3e40be456.tar.bz2
gentoo-d5806bdf4686f5af5f9f7b06741578c3e40be456.zip
sys-apps/plocate: add version 1.1.10
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Closes: https://github.com/gentoo/gentoo/pull/22022 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/plocate/Manifest1
-rw-r--r--sys-apps/plocate/files/plocate-1.1.10-meson-use-feature-option-for-libiouring.patch38
-rw-r--r--sys-apps/plocate/plocate-1.1.10.ebuild81
3 files changed, 120 insertions, 0 deletions
diff --git a/sys-apps/plocate/Manifest b/sys-apps/plocate/Manifest
index 4d4a1d480d44..7a35e770f079 100644
--- a/sys-apps/plocate/Manifest
+++ b/sys-apps/plocate/Manifest
@@ -1 +1,2 @@
+DIST plocate-1.1.10.tar.gz 72222 BLAKE2B 2d84177454380c9e806a46a6e7057aca15b65c9d83179ba35062d0b8772e7cb3ff50d594c294d73157e7705d4b2eea3f12d07e614076e6a6c7a9b532f42640f5 SHA512 eee4a8982b8fff18793cd06c35cdea501226fae6409df02e8bed3d14feb3ed4ba6c29e907f36f5efb74202e8926547def83379b03aeb6348e1a6e7b51f12fdb9
DIST plocate-1.1.8.tar.gz 71569 BLAKE2B 06ad0e9535b76bf0102cdeeb6014e2d84f85f51f5926520566e9c6871f04ac09651bb0674ed679d2a4c0d4e516e55dfef35a7021112fad3549bf76993554aeb5 SHA512 a685347df64ac1a3eb7789cb7023b4d0ffed5fb7435a4bd88c3943991e145a387829532ec0c01d30d851b97b8d3173ff4c7c274775e639b75f0b1b45e5bca2a6
diff --git a/sys-apps/plocate/files/plocate-1.1.10-meson-use-feature-option-for-libiouring.patch b/sys-apps/plocate/files/plocate-1.1.10-meson-use-feature-option-for-libiouring.patch
new file mode 100644
index 000000000000..183c9f8e7fff
--- /dev/null
+++ b/sys-apps/plocate/files/plocate-1.1.10-meson-use-feature-option-for-libiouring.patch
@@ -0,0 +1,38 @@
+From 562128212376305bac8edd10d80c24f1223f1870 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@aarsen.me>
+Date: Thu, 19 Aug 2021 12:03:39 +0200
+Subject: [PATCH plocate] meson: use feature option for libiouring
+
+source-based distributions would prefer to allow this option to be
+disabled without a hack, regardless of is libiouring installed or not,
+and meson already supports feature options for this purpose.
+---
+ meson.build | 2 +-
+ meson_options.txt | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 6fb0f74..fb79e3f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -10,7 +10,7 @@ add_project_arguments('-DPACKAGE_VERSION="' + meson.project_version() + '"', lan
+ add_project_arguments('-DPACKAGE_BUGREPORT="steinar+plocate@gunderson.no"', language: 'cpp')
+
+ cxx = meson.get_compiler('cpp')
+-uringdep = dependency('liburing', required: false)
++uringdep = dependency('liburing', required: get_option('use_libiouring'))
+ zstddep = dependency('libzstd')
+ threaddep = dependency('threads')
+ atomicdep = cxx.find_library('atomic', required: false)
+diff --git a/meson_options.txt b/meson_options.txt
+index 8ac13c5..9c90bf0 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -3,3 +3,4 @@ option('install_systemd', type: 'boolean', value: true, description: 'Install sy
+ option('systemunitdir', type: 'string', description: 'Where to install systemd units to (default: autodetect)')
+ option('locategroup', type: 'string', value: 'plocate', description: 'Group that the install script will use for the .db file')
+ option('updatedb_progname', type: 'string', value: 'updatedb', description: 'Binary name of updatedb')
++option('use_libiouring', type: 'feature', value: 'auto', description: 'Enable libiouring dependency (default: autodetect)')
+--
+2.31.1
+
diff --git a/sys-apps/plocate/plocate-1.1.10.ebuild b/sys-apps/plocate/plocate-1.1.10.ebuild
new file mode 100644
index 000000000000..d198d630c595
--- /dev/null
+++ b/sys-apps/plocate/plocate-1.1.10.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Posting locate is a much faster locate"
+HOMEPAGE="https://plocate.sesse.net/"
+SRC_URI="https://plocate.sesse.net/download/${P}.tar.gz"
+
+# GPL-2 for updatedb
+# GPL-2+ for plocate itself
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+io-uring"
+
+RDEPEND="
+ acct-group/locate
+ app-arch/zstd:=
+ io-uring? ( sys-libs/liburing:= )
+ !sys-apps/mlocate
+"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~IO_URING"
+ERROR_IO_URING="required for USE=io-uring"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.10-meson-use-feature-option-for-libiouring.patch
+)
+
+src_prepare() {
+ # We'll install the manpage ourself to locate.1
+ sed -i "/install_man('plocate.1')/d" meson.build || die
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlocategroup=locate
+ -Dinstall_systemd=true
+ -Dinstall_cron=false
+ -Dsystemunitdir="$(systemd_get_systemunitdir)"
+ "$(meson_feature io-uring use_libiouring)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc README NEWS
+ newman "${S}"/${PN}.1 locate.1
+ dosym plocate /usr/bin/locate
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+ doins "${FILESDIR}"/plocate-cron.conf
+ fperms 0644 /etc/{updatedb,plocate-cron}.conf
+
+ insinto /etc/cron.daily
+ # Ensure that the cron file has the same name as the
+ # systemd-timer, to avoid plocate being run twice daily on systems
+ # with a systemd compatiblity layer. See also bug #780351.
+ newins "${FILESDIR}"/plocate.cron plocate-updatedb
+ fperms 0755 /etc/cron.daily/plocate-updatedb
+
+ systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ elog "The database for the locate command is generated daily by a cron job,"
+ elog "if you install for the first time you can run the updatedb command manually now."
+ elog
+ elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
+ elog "please customize it to your system requirements."
+ fi
+}