summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-31 01:20:09 +0100
committerSam James <sam@gentoo.org>2023-05-31 01:23:02 +0100
commita75ad4d2269a1a9233f9ba60059c2bcec685a587 (patch)
treec91a67fb413a74ea4bb033b53f4c8e86b4cf2aea /sys-apps
parentx11-terms/xterm: add 381 (diff)
downloadgentoo-a75ad4d2269a1a9233f9ba60059c2bcec685a587.tar.gz
gentoo-a75ad4d2269a1a9233f9ba60059c2bcec685a587.tar.bz2
gentoo-a75ad4d2269a1a9233f9ba60059c2bcec685a587.zip
sys-apps/goawk: add 1.23.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/goawk/Manifest1
-rw-r--r--sys-apps/goawk/goawk-1.23.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/goawk/Manifest b/sys-apps/goawk/Manifest
index 8d50b437d60f..6bf08d24f59a 100644
--- a/sys-apps/goawk/Manifest
+++ b/sys-apps/goawk/Manifest
@@ -1,2 +1,3 @@
DIST goawk-1.22.0.tar.gz 1676447 BLAKE2B 315874b8ee6334dd74fc86727340d3e14e01aac08880d562bd6297bcf42ae577e2ab6aa187e2f82616029b2fea9c64074193869fed01a8baa4423a5bfe73f45c SHA512 4109ca6e73f2eb87ef9d5b123634fb01cc92e8867aeec19be3d5b4744c7bd07747330fc6a371adbb52f2cab1fb51b43e9be6d8a851a0f0c5287c6039d497147c
DIST goawk-1.23.0.tar.gz 1678139 BLAKE2B 0289ff64bfcfc7f14e48fc7d0e60e287b52d78d48dc8b21687ccdd13ada1cc8f193b12a112ccb898ef89893cf0f9e5502271f1433d77f21b1db5b1e9df56a4a8 SHA512 e2a8dda1d2a8cad1aee5ec7107cac30ff9aa691c5d0d78d91691dba21921fcbdac1dde4c61aff8a7d1280f174caaefcb44e937df84e0bf46e7818085da26f902
+DIST goawk-1.23.1.tar.gz 1678471 BLAKE2B f87037cdb5f256d5c3848f7fb0e64d81672abfa03c15d9b778fac14804c252ea140b3b436a09ab2189364b180bd1b638ecd66e767dd72532cc0f051ca2255097 SHA512 64f56f5ffa512929aa83d4df0360894ef231fdffe1879a72ed723606db77bf001ee744b646221a6042ef2cd3cb79fc8c80e33cec992b0b8c61da9f41ba78650b
diff --git a/sys-apps/goawk/goawk-1.23.1.ebuild b/sys-apps/goawk/goawk-1.23.1.ebuild
new file mode 100644
index 000000000000..e138a7adbd3d
--- /dev/null
+++ b/sys-apps/goawk/goawk-1.23.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="POSIX-compliant AWK interpreter written in Go, with CSV support"
+HOMEPAGE="https://github.com/benhoyt/goawk"
+SRC_URI="https://github.com/benhoyt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+src_compile() {
+ ego build
+}
+
+src_test() {
+ ego test
+}
+
+src_install() {
+ einstalldocs
+
+ dobin goawk
+}