summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-07 08:06:53 +0100
committerSam James <sam@gentoo.org>2024-10-07 08:07:25 +0100
commit9264246a123d854b9251da9e9665a3edcbaf9c71 (patch)
tree790e7f8ccd4690ca6fed0d06f3e7e156fd8895f1 /sys-apps
parentmedia-gfx/gnofract4d: add 4.3_p20240821 (diff)
downloadgentoo-9264246a123d854b9251da9e9665a3edcbaf9c71.tar.gz
gentoo-9264246a123d854b9251da9e9665a3edcbaf9c71.tar.bz2
gentoo-9264246a123d854b9251da9e9665a3edcbaf9c71.zip
sys-apps/file: enable py3.13, wire up python tests
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/file-5.45-r4.ebuild15
-rw-r--r--sys-apps/file/file-9999.ebuild38
2 files changed, 42 insertions, 11 deletions
diff --git a/sys-apps/file/file-5.45-r4.ebuild b/sys-apps/file/file-5.45-r4.ebuild
index 48a5067c2cd2..84ced37c5487 100644
--- a/sys-apps/file/file-5.45-r4.ebuild
+++ b/sys-apps/file/file-5.45-r4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 toolchain-funcs multilib-minimal
@@ -155,6 +155,19 @@ src_compile() {
fi
}
+src_test() {
+ multilib-minimal_src_test
+
+ if use python ; then
+ cd python || die
+ distutils-r1_src_test
+ fi
+}
+
+python_test() {
+ eunittest
+}
+
multilib_src_install() {
if multilib_is_native_abi ; then
default
diff --git a/sys-apps/file/file-9999.ebuild b/sys-apps/file/file-9999.ebuild
index 9ea68ce9ec0c..84ced37c5487 100644
--- a/sys-apps/file/file-9999.ebuild
+++ b/sys-apps/file/file-9999.ebuild
@@ -5,20 +5,20 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1 libtool toolchain-funcs multilib-minimal
+inherit distutils-r1 toolchain-funcs multilib-minimal
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/glensc/file.git"
inherit autotools git-r3
else
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/file.asc
- inherit verify-sig
+ inherit autotools verify-sig
SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz"
SRC_URI+=" verify-sig? ( ftp://ftp.astron.com/pub/file/${P}.tar.gz.asc )"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
BDEPEND="verify-sig? ( sec-keys/openpgp-keys-file )"
fi
@@ -59,17 +59,22 @@ QA_CONFIG_IMPL_DECL_SKIP=( makedev )
PATCHES=(
"${FILESDIR}/file-5.43-seccomp-fstatat64-musl.patch" #789336, not upstream yet
- "${FILESDIR}/file-5.43-portage-sandbox.patch" #889046
+ "${FILESDIR}/file-5.45-seccomp-sandbox.patch"
+ "${FILESDIR}/${P}-32-bit-time_t.patch"
+ "${FILESDIR}/${P}-32-bit-time_t-deux.patch"
+ "${FILESDIR}/${P}-weak-magic-shell.patch" #908401
)
src_prepare() {
default
- if [[ ${PV} == 9999 ]] ; then
- eautoreconf
- else
- elibtoolize
- fi
+ #if [[ ${PV} == 9999 ]] ; then
+ # eautoreconf
+ #else
+ # elibtoolize
+ #fi
+ # Just for file-5.45-32-bit-time_t-deux.patch, drop in 5.46
+ eautoreconf
# Don't let python README kill main README, bug #60043
mv python/README.md python/README.python.md || die
@@ -150,6 +155,19 @@ src_compile() {
fi
}
+src_test() {
+ multilib-minimal_src_test
+
+ if use python ; then
+ cd python || die
+ distutils-r1_src_test
+ fi
+}
+
+python_test() {
+ eunittest
+}
+
multilib_src_install() {
if multilib_is_native_abi ; then
default