summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-29 00:09:32 +0000
committerSam James <sam@gentoo.org>2024-10-29 00:30:15 +0000
commit9043aa091754aaaa3a91494917d6d48a34d8a38d (patch)
treeffaa1c1cf71903c067deaaccc56f6fdabeea53c6 /sys-apps
parentkde-plasma/kwin: set cap_sys_nice=ep on kwin_wayland (diff)
downloadgentoo-9043aa091754aaaa3a91494917d6d48a34d8a38d.tar.gz
gentoo-9043aa091754aaaa3a91494917d6d48a34d8a38d.tar.bz2
gentoo-9043aa091754aaaa3a91494917d6d48a34d8a38d.zip
sys-apps/texinfo: add 7.1.90 (unkeyworded)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/texinfo/Manifest1
-rw-r--r--sys-apps/texinfo/texinfo-7.1.90.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index a8ce96b667d8..f8e9ad7a4645 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -1,2 +1,3 @@
DIST texinfo-7.1.1.tar.xz 5572864 BLAKE2B 64dbd315e65d5b7cb0bb06c918e9924bb15a25a4bb26322db10b7ee98e9e6626b62592f8edd0ff016256f4a84837dabacb5278c3826e34fa3e080a5e8c0fb626 SHA512 05d605fba810f2939cab16ed5ddb341e22d397370648e6e0271c807fa573267e933c75ed7ae682c3c9cfecb568311a8df7abeb8c0556a94ef7169737d5b9c52a
+DIST texinfo-7.1.90.tar.xz 6694376 BLAKE2B b77771e39f8c73cea9c449c1f4268dcdb9603497b719dda036908122805f2f4f85507ee797d7d9d1f4c3e4de236a7be6837c2985d7f10960e347860d98c49a8c SHA512 ecf6359c256c3c203fac26d211b4fad738e5e7cb142005a73df22eb17888296eac17d4748551243fee1f1cf891e612deeeb85bc841c8b64acb99e7fa49d1c3ad
DIST texinfo-7.1.tar.xz 5545720 BLAKE2B 4385ca6250daeaa4f6bfedd9ab41f25993613031bcb8da55360365701213f4f3cf786d958749c59dc1c9dda328eca42f028aa051a7062313142aa92f55a96ecd SHA512 ceab03e8422d800b08c7b44e8263b0a1f35bb7758d83a81136df6f3304a14daecda98a12a282afb85406d2ca2f665b2295e10b6f4064156ea1285d80d5d355db
diff --git a/sys-apps/texinfo/texinfo-7.1.90.ebuild b/sys-apps/texinfo/texinfo-7.1.90.ebuild
new file mode 100644
index 000000000000..eda59950b465
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-7.1.90.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+# Keep an eye on the release/$(ver_cut 1-2) branch upstream for backports.
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/texinfo.git"
+ REGEN_BDEPEND="
+ >=dev-build/autoconf-2.62
+ >=dev-build/automake-1.16
+ dev-build/libtool
+ "
+elif [[ $(ver_cut 3) -ge 90 || $(ver_cut 4) -ge 90 ]] ; then
+ SRC_URI="https://alpha.gnu.org/gnu/${PN}/${P}.tar.xz"
+ REGEN_BDEPEND=""
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ REGEN_BDEPEND=""
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="nls +standalone static"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2-r2:=
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ virtual/perl-Unicode-Collate
+ standalone? ( >=dev-lang/perl-5.8.1 )
+ !standalone? (
+ >=dev-lang/perl-5.8.1:=
+ dev-libs/libunistring:=
+ )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${REGEN_BDEPEND}
+ nls? ( >=sys-devel/gettext-0.19.6 )
+"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ ./autogen.sh || die
+ fi
+
+ # Needed if a patch touches install-info.c
+ #touch man/install-info.1 || die
+
+ if use prefix ; then
+ sed -i -e '1c\#!/usr/bin/env sh' util/texi2dvi util/texi2pdf || die
+ touch {doc,man}/{texi2dvi,texi2pdf,pdftexi2dvi}.1 || die
+ fi
+}
+
+src_configure() {
+ # Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions
+ # bug #622576
+ local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}"
+ local -x PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
+
+ use static && append-ldflags -static
+
+ # TODO:
+ # --with-external-Unicode-EastAsianWidth
+ # --with-external-Text-Unidecode
+ #
+ # Also, 7.0.91 seemed to introduce a included-libunistring w/ USE=-standalone
+ # but it doesn't seem to do anything?
+ local myeconfargs=(
+ --cache-file="${S}"/config.cache
+ $(use_enable nls)
+ $(use_enable !standalone perl-xs)
+ )
+
+ econf "${myeconfargs[@]}"
+}