summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2024-08-05 03:44:11 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-23 01:21:22 -0400
commit2597554bfef3e611db364c0846318a2c05fffa9f (patch)
tree08ea5327826f698c3650c4a7e2accd30fdbd4561 /sys-apps/xdg-desktop-portal-xapp
parentx11-wm/muffin: drop 6.0.1-r1 (diff)
downloadgentoo-2597554bfef3e611db364c0846318a2c05fffa9f.tar.gz
gentoo-2597554bfef3e611db364c0846318a2c05fffa9f.tar.bz2
gentoo-2597554bfef3e611db364c0846318a2c05fffa9f.zip
sys-apps/xdg-desktop-portal-xapp: add 1.0.9
Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal-xapp')
-rw-r--r--sys-apps/xdg-desktop-portal-xapp/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-xapp/files/xdg-desktop-portal-xapp-1.0.9-remove-gdk-refs.patch35
-rw-r--r--sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.9.ebuild42
3 files changed, 78 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-xapp/Manifest b/sys-apps/xdg-desktop-portal-xapp/Manifest
index 66395ce49dbc..dce5c822d771 100644
--- a/sys-apps/xdg-desktop-portal-xapp/Manifest
+++ b/sys-apps/xdg-desktop-portal-xapp/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-xapp-1.0.4.tar.gz 88429 BLAKE2B 7f45a252a5c0dd433238a58012c65369240e7974a93d3d2b5b73bdbc91509480977ad1ce381a6f4ee3a0c87bfabd11ce87bf99839018811a84378e54be1ef36f SHA512 3f861473a763c37a1af95e3beb13c3364a04f557310d5a6520845bc754941149eb3d80a4e2893699715ff11b135edb2859f6349b6aa6fbe0aa1e173263e22dba
DIST xdg-desktop-portal-xapp-1.0.8.tar.gz 90500 BLAKE2B edef095868df23e671810db10f162bf72ad50132100910a6e097c08da6d02ff216c110bf3bc597d85c9d380f6857216dec6ca62b4acda1b152e1fc7b99684822 SHA512 0baae8a4a260396ea0b17a76be100a535588411a8f66a085b2dfd577fe6141d53dcb48e2085223359d1f5f691c5a16aa0d7a496ff08a94a00486c597f77aae84
+DIST xdg-desktop-portal-xapp-1.0.9.tar.gz 90661 BLAKE2B dc7ec9ff18516a892bdbf184ae8d3730a4f2c38ba091830c55500fdf61d6bb87abcfc56638c51e42374e29957e47c3090addaad7d7167a119bfb3cd43d3d5d57 SHA512 7badd5e41e610647dcece7c5344be03816ed08a226a6667d9484e8e4560396eb8dab2140edf977d7038bf3f21ce8b8d6516bf041af9c92bf024274faf35e2037
diff --git a/sys-apps/xdg-desktop-portal-xapp/files/xdg-desktop-portal-xapp-1.0.9-remove-gdk-refs.patch b/sys-apps/xdg-desktop-portal-xapp/files/xdg-desktop-portal-xapp-1.0.9-remove-gdk-refs.patch
new file mode 100644
index 000000000000..948fb6ad91f4
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-xapp/files/xdg-desktop-portal-xapp-1.0.9-remove-gdk-refs.patch
@@ -0,0 +1,35 @@
+From b364687b8a696c78f2d3c46e0c45c2dc28e79a33 Mon Sep 17 00:00:00 2001
+From: Michael Webster <miketwebster@gmail.com>
+Date: Sat, 10 Aug 2024 08:06:28 -0400
+Subject: [PATCH] Remove Gdk references and meson dependency.
+
+ref: 54fca8b5b6a2b
+---
+ src/meson.build | 1 -
+ src/settings.c | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/src/meson.build b/src/meson.build
+index f4128c8..a3e8aa5 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -61,7 +61,6 @@ deps = [
+ meson.get_compiler('c').find_library('m'),
+ dependency('glib-2.0', version: '>= 2.44'),
+ dependency('gio-unix-2.0'),
+- dependency('gdk-3.0'),
+ xdg_desktop_portal_dep,
+ ]
+
+diff --git a/src/settings.c b/src/settings.c
+index 55014fb..1e77664 100644
+--- a/src/settings.c
++++ b/src/settings.c
+@@ -24,7 +24,6 @@
+ #include <string.h>
+ #include <glib/gi18n.h>
+ #include <gio/gio.h>
+-#include <gdk/gdk.h>
+
+ #include "settings.h"
+ #include "utils.h"
diff --git a/sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.9.ebuild b/sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.9.ebuild
new file mode 100644
index 000000000000..21bf46038390
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Cinnamon/MATE/Xfce"
+HOMEPAGE="https://github.com/linuxmint/xdg-desktop-portal-xapp/"
+SRC_URI="https://github.com/linuxmint/xdg-desktop-portal-xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=sys-apps/xdg-desktop-portal-1.5
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal-gtk
+ >=x11-libs/xapp-2.8.4
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Remove orphaned gdk references
+ # https://github.com/linuxmint/xdg-desktop-portal-xapp/commit/b364687b8a696c78f2d3c46e0c45c2dc28e79a33
+ "${FILESDIR}/${PN}-${PV}-remove-gdk-refs.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+ meson_src_configure
+}