summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-12 19:14:42 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-12 19:14:59 -0400
commita77f715beab04827be1ba9067c3037b77e2625e8 (patch)
tree80de7f473fb4f411819ff19f343c15141ac7aeb4 /sys-apps/xdg-dbus-proxy
parentsys-apps/portage: add pypi upstream metadata (diff)
downloadgentoo-a77f715beab04827be1ba9067c3037b77e2625e8.tar.gz
gentoo-a77f715beab04827be1ba9067c3037b77e2625e8.tar.bz2
gentoo-a77f715beab04827be1ba9067c3037b77e2625e8.zip
sys-apps/xdg-dbus-proxy: Version bump to 0.1.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-dbus-proxy')
-rw-r--r--sys-apps/xdg-dbus-proxy/Manifest1
-rw-r--r--sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/xdg-dbus-proxy/Manifest b/sys-apps/xdg-dbus-proxy/Manifest
index f015523ab703..8415c4f59ee3 100644
--- a/sys-apps/xdg-dbus-proxy/Manifest
+++ b/sys-apps/xdg-dbus-proxy/Manifest
@@ -1 +1,2 @@
DIST xdg-dbus-proxy-0.1.3.tar.xz 119896 BLAKE2B c789ad697c1cda84a4cde2c84b90370869bdaeb76736c2891270a58834296e3acbf83b311ba153a0d1e9f3266de0cc1eda63866e2808dcbb4aeac451f90da7f6 SHA512 bb730366efca9d0d199983063dd5cd7b8a8aac8d9efd8e3d6b6090166e5e09a74ef241a07388cfbb2f108e66b3a29114671a6d955324626aebefa1d6c2423632
+DIST xdg-dbus-proxy-0.1.4.tar.xz 122112 BLAKE2B c7d2898b703c51d6b53838996a0ae74e7a4e163b9611e28dfded54ab1a44c0473fa25daa13e94977c918544e0741bf0dd4747dfcae858468bc4abd288613cb8b SHA512 d50fa916d07f23e080ab53cf290b5d6db73cfd8262253a48b9f012ce6c182e201d0a67efaeb7f28a844d3ef146aa48936dfbe4279a59b909a6dc4419d5f15b04
diff --git a/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.4.ebuild b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.4.ebuild
new file mode 100644
index 000000000000..23744c014949
--- /dev/null
+++ b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Filtering proxy for D-Bus connections"
+HOMEPAGE="https://github.com/flatpak/xdg-dbus-proxy"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman=enabled
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}