summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-04-24 12:52:11 +0100
committerMarek Szuba <marecki@gentoo.org>2024-04-24 12:58:00 +0100
commit3ec97ea5d7cabb2666b0999be073eb77bc21a78f (patch)
tree5bb9c61db052c33eb15f87f46f75e726dd18a4ac /sys-apps/uswid
parentdev-ruby/pcaprub: avoid tests that require network or devices (diff)
downloadgentoo-3ec97ea5d7cabb2666b0999be073eb77bc21a78f.tar.gz
gentoo-3ec97ea5d7cabb2666b0999be073eb77bc21a78f.tar.bz2
gentoo-3ec97ea5d7cabb2666b0999be073eb77bc21a78f.zip
sys-apps/uswid: new package, add 0.4.7
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-apps/uswid')
-rw-r--r--sys-apps/uswid/Manifest1
-rw-r--r--sys-apps/uswid/metadata.xml22
-rw-r--r--sys-apps/uswid/uswid-0.4.7.ebuild28
3 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/uswid/Manifest b/sys-apps/uswid/Manifest
new file mode 100644
index 000000000000..38644d7715a0
--- /dev/null
+++ b/sys-apps/uswid/Manifest
@@ -0,0 +1 @@
+DIST uswid-0.4.7.tar.gz 43719 BLAKE2B c99ea760658a5b5f518e6e8aa554515bc0a5246d60c358b6542dda17489fe18f06b2dff7342371944fe36c44562f9e78feb230f6573445c4004568c973b66b87 SHA512 6e8069547efbc06ee5e2792908a292e70612041f303b41d54fc618519f3156a8c88ca9176367c47304dbe80b0199467b913060c8fdbcef1287794cac0a9e695c
diff --git a/sys-apps/uswid/metadata.xml b/sys-apps/uswid/metadata.xml
new file mode 100644
index 000000000000..36b5e41b4afc
--- /dev/null
+++ b/sys-apps/uswid/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ Using the uSWID tool or Python API allows one to create, convert and merge
+ Software Bill of Materials (SBoM) metadata to and from a number of different
+ formats including SWID, coSWID, CycloneDX, SPDX and goSWID. It can also import
+ SBoM metadata from .ini files, pkgconfig files, PE binaries including EFI ones,
+ and various unspecified firmware files as long as they include the coSWID SBoM
+ header. Last but not least, it can be used to embed coSWID SBoM metadata
+ into PE/EFI binaries.
+ </longdescription>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">uswid</remote-id>
+ <remote-id type="github">hughsie/python-uswid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/uswid/uswid-0.4.7.ebuild b/sys-apps/uswid/uswid-0.4.7.ebuild
new file mode 100644
index 000000000000..0d7c386217e0
--- /dev/null
+++ b/sys-apps/uswid/uswid-0.4.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure-Python library and CLI tool for processing SBoM metadata"
+HOMEPAGE="
+ https://github.com/hughsie/python-uswid/
+ https://pypi.org/project/uswid/
+"
+
+# Reminder: relicensed to BSD-2-with-patent between 0.4.7 and 0.5.0
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/cbor2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pefile[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest