summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-08-06 20:01:24 -0400
committerMike Gilbert <floppym@gentoo.org>2021-08-06 20:01:24 -0400
commit0be0c443ad8ffecd09a2231f4fb3b0b3707b7d7f (patch)
treee101669fa5ffd4fb4cf8851a0c36abc049651675 /sys-apps/systemd
parentdev-python/flask-nav: make Python 3.10 really work (diff)
downloadgentoo-0be0c443ad8ffecd09a2231f4fb3b0b3707b7d7f.tar.gz
gentoo-0be0c443ad8ffecd09a2231f4fb3b0b3707b7d7f.tar.bz2
gentoo-0be0c443ad8ffecd09a2231f4fb3b0b3707b7d7f.zip
sys-apps/systemd: add python3.10
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/systemd-249.2.ebuild3
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild3
2 files changed, 2 insertions, 4 deletions
diff --git a/sys-apps/systemd/systemd-249.2.ebuild b/sys-apps/systemd/systemd-249.2.ebuild
index 9e5fa453bcfd..da6cc62575f2 100644
--- a/sys-apps/systemd/systemd-249.2.ebuild
+++ b/sys-apps/systemd/systemd-249.2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
@@ -19,8 +20,6 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-PYTHON_COMPAT=( python3_{7..9} )
-
inherit bash-completion-r1 linux-info meson-multilib pam python-any-r1 systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="System and service manager for Linux"
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 71b8f9c1b29c..260f9ce67e0f 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
@@ -19,8 +20,6 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-PYTHON_COMPAT=( python3_{7..9} )
-
inherit bash-completion-r1 linux-info meson-multilib pam python-any-r1 systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="System and service manager for Linux"