summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-08-05 20:50:57 -0400
committerMike Gilbert <floppym@gentoo.org>2023-08-05 20:51:49 -0400
commit761c8d19f1549cd137d2b0a0cbcb12f569dfba5e (patch)
treedd5e4437bb10a097f0a36bec37a0a0d9246f7b3f /sys-apps/sandbox
parentdev-python/tqdm: keyword 4.65.0 for ~arm64-macos (diff)
downloadgentoo-761c8d19f1549cd137d2b0a0cbcb12f569dfba5e.tar.gz
gentoo-761c8d19f1549cd137d2b0a0cbcb12f569dfba5e.tar.bz2
gentoo-761c8d19f1549cd137d2b0a0cbcb12f569dfba5e.zip
sys-apps/sandbox: add 2.38
Closes: https://bugs.gentoo.org/906234 Closes: https://bugs.gentoo.org/910273 Closes: https://bugs.gentoo.org/910561 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/Manifest1
-rw-r--r--sys-apps/sandbox/sandbox-2.38.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index 5a7a26d89784..82911784c70d 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -2,3 +2,4 @@ DIST sandbox-2.32.tar.xz 456724 BLAKE2B 95eed293ef9427726f62d0d7ac1a0c63bbfd152d
DIST sandbox-2.35.tar.xz 459228 BLAKE2B 72a7b48d0bb9021b65093f7ab8ed98e3fecb2544869c67a4cc00e829f3885d936320fa452f8807e95123e75cd14cfaf1797015c17dd30e40ba8694665c9d7e9c SHA512 ba3351c4e6aea2a4390c6d66a7d9de0b4c80e0e6c8a2cb298cb30dcaeeb1618f66d75055ac00c0d8f169a29c9c3175bec5e95a4228f93f353a1d8c8d0a07d177
DIST sandbox-2.36.tar.xz 459348 BLAKE2B e0544e6e37533009939a6756f4d6c0f5c4aada4679bff539c65dd602024d85d70550912a4128223c691400664fd8e75cefad504e03516b3421cf7c6befdf5fcd SHA512 6590887f0e56ee322d7ff2e55041bfa6cf8edc77f0369a8dcf2287dce5fb7ba845b0336c7d8bb91b2c50e7b9a4f1e52eecaee1d2381d25bb260ea9fd2f9d4587
DIST sandbox-2.37.tar.xz 459420 BLAKE2B 0f6c701f819139f557a5fccb59e67509b04ba6eb22e79250a69ae990b123f9f7b618bb82a43ea86e1b18614c38d0d884aceb77d17af5a92030b2b4ad89eb2bd4 SHA512 91ddb98aa118f2d606aaf64b20598dbed9239069350842ab9fd3af05b1942380c92841d044387bc2d761317faa9c44848b3010e18747d834c115929f64060056
+DIST sandbox-2.38.tar.xz 460776 BLAKE2B 39a93e77301d5b6ea0a352cf1dc7786a1030a3701b0f8beca62e80a4f0d614b26cb3764ecf0174a9fd77acf27ae5d972de352e6fdec5a169aba83e6146a84038 SHA512 a559e32654b2fd7baca70b85f6dbf0a610e5847ccf28d7a0536485aedbfb1ce8394a080e6efdafcf76e01439b2592eebcef6c8f77a976188ce7e3759a2844d3f
diff --git a/sys-apps/sandbox/sandbox-2.38.ebuild b/sys-apps/sandbox/sandbox-2.38.ebuild
new file mode 100644
index 000000000000..1efc83d19f22
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-2.38.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic multilib-minimal multiprocessing
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+nnp"
+
+# pax-utils lower bound for bug #265376
+DEPEND=">=app-misc/pax-utils-0.1.19"
+# Avoid folks installing with older file, bug #889046. We still need the
+# >= dep in Portage but this is a safety net if people do partial upgrades.
+RDEPEND="!<sys-apps/file-5.44-r1"
+BDEPEND="app-arch/xz-utils"
+
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS+=" sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
+}
+
+src_prepare() {
+ default
+
+ if ! use nnp ; then
+ sed -i 's:PR_SET_NO_NEW_PRIVS:___disable_nnp_hack:' src/sandbox.c || die
+ fi
+
+ # sandbox uses `__asm__ (".symver "...` which does
+ # not play well with gcc's LTO: https://gcc.gnu.org/PR48200
+ filter-lto
+}
+
+multilib_src_configure() {
+ filter-lfs-flags #90228
+
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_test() {
+ # Default sandbox build will run with --jobs set to # cpus.
+ emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
+}
+
+multilib_src_install_all() {
+ doenvd "${FILESDIR}"/09sandbox
+
+ dodoc AUTHORS ChangeLog* README.md
+}
+
+pkg_postinst() {
+ mkdir -p "${EROOT}"/var/log/sandbox
+ chown root:portage "${EROOT}"/var/log/sandbox
+ chmod 0770 "${EROOT}"/var/log/sandbox
+}