summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-10 19:28:26 +0100
committerSam James <sam@gentoo.org>2022-10-10 19:32:56 +0100
commit4e487cc0c3a60289c30ed886d0ecae85b4cc44d8 (patch)
tree52d577f9f29a516e5c33fff39f10163b21961575 /sys-apps/hwdata
parentdev-cpp/tbb: add 2021.7.0 (diff)
downloadgentoo-4e487cc0c3a60289c30ed886d0ecae85b4cc44d8.tar.gz
gentoo-4e487cc0c3a60289c30ed886d0ecae85b4cc44d8.tar.bz2
gentoo-4e487cc0c3a60289c30ed886d0ecae85b4cc44d8.zip
sys-apps/hwdata: add 0.363
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/hwdata')
-rw-r--r--sys-apps/hwdata/Manifest1
-rw-r--r--sys-apps/hwdata/hwdata-0.363.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/hwdata/Manifest b/sys-apps/hwdata/Manifest
index f07671e6b0eb..377f99765f57 100644
--- a/sys-apps/hwdata/Manifest
+++ b/sys-apps/hwdata/Manifest
@@ -1,2 +1,3 @@
DIST hwdata-0.361.tar.gz 2263204 BLAKE2B 83f613dd75e677bb25e884c00e8c32aa97e1b030ac8642df2c35f895df815bf6b8c3333a150c448fb6a14a8cf6c6cec9ef351896a5762a45ea99c34c39790213 SHA512 942cf6fa17c2f6fa41d7c624aa7fd28d57d6ad7750eb7a01c8ce85a663154140af75108a8ab12d43375bae63574a594ea2117195a743c12e5c4cb2986f198454
DIST hwdata-0.362.tar.gz 2277092 BLAKE2B fa0fb6055e65867a61ff628655c45442f175daf6c4d29b921356534a6aca686d6790fab6fd930707fb81891dac4325078a335f351af236d4eece8953703b2c27 SHA512 63ea6b56283b248a54b4a9e350da431db4f40b30e4d1e9afb29bfec3f87b11723899397817435e9142b7775690a399591afb9b701101e2cc4d78893fa791e1b7
+DIST hwdata-0.363.tar.gz 2283349 BLAKE2B dd7aa9c7d202882a31a5359cf674c9399b23b07f47d2fa706739201f60227922572619cef42f50835c4a01efab19773e24b0540a87f759b805755389f8d6f7f4 SHA512 b53ffad2bdeea1ac8c78832e693c44655dc86c401a3f6921ccedf45a88731d82b40b2f033bb90bcaa058b1b3e8361a90aa4eeba9779ee4741efc40ae8ff6282a
diff --git a/sys-apps/hwdata/hwdata-0.363.ebuild b/sys-apps/hwdata/hwdata-0.363.ebuild
new file mode 100644
index 000000000000..9df06b92fe5f
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.363.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+
+ edo "${conf[@]}"
+}