summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-20 03:10:39 +0100
committerSam James <sam@gentoo.org>2023-07-20 03:10:39 +0100
commitdd271b5e7cbd9cd65f33b63d7be47ef35af880a2 (patch)
tree1c0a8c598c97e91b445b7909edce320655486257 /sys-apps/goawk
parentdev-util/diffoscope: add 244 (diff)
downloadgentoo-dd271b5e7cbd9cd65f33b63d7be47ef35af880a2.tar.gz
gentoo-dd271b5e7cbd9cd65f33b63d7be47ef35af880a2.tar.bz2
gentoo-dd271b5e7cbd9cd65f33b63d7be47ef35af880a2.zip
sys-apps/goawk: add 1.24.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/goawk')
-rw-r--r--sys-apps/goawk/Manifest1
-rw-r--r--sys-apps/goawk/goawk-1.24.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/goawk/Manifest b/sys-apps/goawk/Manifest
index f111ee9ba3ff..faa3a5d561c6 100644
--- a/sys-apps/goawk/Manifest
+++ b/sys-apps/goawk/Manifest
@@ -1,2 +1,3 @@
DIST goawk-1.23.2.tar.gz 1682245 BLAKE2B 6f7c87717ae3539272688c600705ca9757f38671dd2d73688ff4b3e345d66e2cf7b16f7bc6d0dd97340cf84b8a09bb116207ec5dfb361ff5721ffe99c048c118 SHA512 b448b99cb880b23de72fc77948217291b9da6733ad8538d7978e3dbd83e233ac6c558a39bc7d995002bb6b67c6b6ed5ac3a4131b90f43443bdd7c639b793f5ee
DIST goawk-1.23.3.tar.gz 1682899 BLAKE2B e0ca6001b5adc78186549cbf11bc016294a996e8a1337227a1915e30b5f04786cf443c19c8daaae5e4e0604945783bc89a4a173f1f878685f7330f4f3933690e SHA512 06955b9cf53ac7a4a414ea18b4886fa71f1ec3ca1338a6648f9650f28ba5f52d672eddb7b5f8462fb404966b716f9a1ac8b6e075ab74883e6d1ad1a16314f4f8
+DIST goawk-1.24.0.tar.gz 1684298 BLAKE2B 4a13994ba99d35ebbf42077a68c21842ccd2ad85d0d31976fc0aa7c999d926a090e2d21c6313498b436d580d231449729e67a20717d0efd4f79e96a3bfb89c36 SHA512 2ae955fe35e6b08bf997c136aa7b8ece1de21bebc442a1757eeac44aa545be5eaa58d6a6b3c827dcfebff6a1d55332e1b0b48dbf07c39273f3d2bac221d8f218
diff --git a/sys-apps/goawk/goawk-1.24.0.ebuild b/sys-apps/goawk/goawk-1.24.0.ebuild
new file mode 100644
index 000000000000..e138a7adbd3d
--- /dev/null
+++ b/sys-apps/goawk/goawk-1.24.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="POSIX-compliant AWK interpreter written in Go, with CSV support"
+HOMEPAGE="https://github.com/benhoyt/goawk"
+SRC_URI="https://github.com/benhoyt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+src_compile() {
+ ego build
+}
+
+src_test() {
+ ego test
+}
+
+src_install() {
+ einstalldocs
+
+ dobin goawk
+}