summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-04-02 20:00:13 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-04-02 20:01:10 +0200
commit7d2d42aa8604aee045c2d0e41384856970667b08 (patch)
tree6aed0238e597299a5ec39a02e608ce862e3434d3 /sys-apps/cpuid
parentdev-db/influxdb: add 2.7.5 (diff)
downloadgentoo-7d2d42aa8604aee045c2d0e41384856970667b08.tar.gz
gentoo-7d2d42aa8604aee045c2d0e41384856970667b08.tar.bz2
gentoo-7d2d42aa8604aee045c2d0e41384856970667b08.zip
sys-apps/cpuid: add 20240330
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20240330.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index e438bca2dc92..197444b74fb9 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20230614.src.tar.gz 149777 BLAKE2B 5ebfd7d055f2b67cd158dd6eaa5467a5776170a879a4323e2dc103e8b84f4cf72523d5ae5272d2f89ae6555f597d903bdf149f279f9565bf88a1e26b0e574606 SHA512 46698e5565d1c558e50b9526154489d82ada64ea5dbcebc01e3cd34b79b2b646f324deaf7d63678cd477d227e902437c3ff6c7998b4385ddd373aa1fc76ff70c
+DIST cpuid-20240330.src.tar.gz 154968 BLAKE2B c859b2e66044ce622daf695e951666fbeaad4e529cf764cb86dd7e43837327dc21aaaae98cfd915663560f5b33af1497ee9af9e1e02dba7345456e9aa6948c4a SHA512 a35bcf730a9945df029159f5f851b212fd3c07ab94dfb680d4ebdd541dfbc5fdee1cd269fe0d1f14e9678f78c41c47f2c54621cfe81a93e3b4c5c1194f9be9ee
diff --git a/sys-apps/cpuid/cpuid-20240330.ebuild b/sys-apps/cpuid/cpuid-20240330.ebuild
new file mode 100644
index 000000000000..d1563143acef
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20240330.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}