summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-07-14 14:00:02 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-07-14 14:00:02 +0200
commit63fdc6af981150f710f3bac4fb1191a173c449f4 (patch)
treeab26ffc8434bb47cfaa6483432481f4ec049cdbc /sys-apps/cpuid
parentapp-misc/graphlcd-base: update HOMEPAGE, SRC_URI (diff)
downloadgentoo-63fdc6af981150f710f3bac4fb1191a173c449f4.tar.gz
gentoo-63fdc6af981150f710f3bac4fb1191a173c449f4.tar.bz2
gentoo-63fdc6af981150f710f3bac4fb1191a173c449f4.zip
sys-apps/cpuid: add 20240709
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20240709.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index 168d49f89205..bbf599f73af1 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20240409.src.tar.gz 155607 BLAKE2B 0becfb559137cb4b965b3d9e34c3f6d8875634c6ea46afb4a61c9dabd437c345859dce99c5e05fa54b9945a4d2a001dba14b87825ed2b76344571745c072ae07 SHA512 04b3165d2441e4572754412eda330632bd6c0a2a16df4114231030cb991789ecf5507e1ea52f9ea1c84a43b2d190a95d07a6ee2788d8f8a2a6414da127751a36
+DIST cpuid-20240709.src.tar.gz 156034 BLAKE2B c7487a0b9a21593d32df4a2eb42bf4deb7a357155d1dd28ec3d485349b7a3164f5a7c3ecb3b65c1c88c5c1a9132d158a33568d6f5d9398e0b8a75c54dd86f824 SHA512 c89d6d9a332c80a78698f3862dbb0e17df793b389ae6d522c9c68cb2818b932d7653f7c8d7e5344918b7e93f944c8f7ea02276148df4f25b720d4561fc6698ed
diff --git a/sys-apps/cpuid/cpuid-20240709.ebuild b/sys-apps/cpuid/cpuid-20240709.ebuild
new file mode 100644
index 000000000000..c2868c0d5525
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20240709.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}