summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-02-24 16:50:01 -0500
committerMike Gilbert <floppym@gentoo.org>2021-02-24 16:50:01 -0500
commitc12fe9edfa7d6b9a1ce4fc387ea3f134955c2fa8 (patch)
treeec020431bb9549336120cc8b42081f2ef4baa1d9 /sys-apps/acl
parentsys-apps/acl: skip tests for non-native abis (diff)
downloadgentoo-c12fe9edfa7d6b9a1ce4fc387ea3f134955c2fa8.tar.gz
gentoo-c12fe9edfa7d6b9a1ce4fc387ea3f134955c2fa8.tar.bz2
gentoo-c12fe9edfa7d6b9a1ce4fc387ea3f134955c2fa8.zip
sys-apps/acl: remove old
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/acl-2.2.53.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-apps/acl/acl-2.2.53.ebuild b/sys-apps/acl/acl-2.2.53.ebuild
deleted file mode 100644
index bb450925ad94..000000000000
--- a/sys-apps/acl/acl-2.2.53.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic libtool toolchain-funcs multilib-minimal usr-ldscript
-
-DESCRIPTION="access control list utilities, libraries and headers"
-HOMEPAGE="https://savannah.nongnu.org/projects/acl"
-SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="nls static-libs"
-
-RDEPEND="
- >=sys-apps/attr-2.4.47-r1[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- # filter out -flto flags as they break getfacl/setfacl binaries
- # (bug #667372)
- filter-flags -flto*
-}
-
-src_prepare() {
- default
- elibtoolize #580792
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}"/bin
- $(use_enable static-libs static)
- --libexecdir="${EPREFIX}"/usr/$(get_libdir)
- $(use_enable nls)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install() {
- default
-
- # move shared libs to /
- gen_usr_ldscript -a acl
-}
-
-multilib_src_install_all() {
- if ! use static-libs ; then
- find "${ED}" -type f -name "*.la" -delete || die
- fi
-}