summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-06-03 11:20:44 -0400
committerBrian Evans <grknight@gentoo.org>2021-06-03 11:20:44 -0400
commit3bd3bfa699f84498d2af1fb27ea4feb9cacdf5e8 (patch)
treec705455cbaa7fcc25bdf33ee38af9a283093bef3 /sys-apps/ack/ack-3.5.0.ebuild
parentx11-themes/papirus-icon-theme: drop older (diff)
downloadgentoo-3bd3bfa699f84498d2af1fb27ea4feb9cacdf5e8.tar.gz
gentoo-3bd3bfa699f84498d2af1fb27ea4feb9cacdf5e8.tar.bz2
gentoo-3bd3bfa699f84498d2af1fb27ea4feb9cacdf5e8.zip
sys-apps/ack: Version bump for 3.5.0
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'sys-apps/ack/ack-3.5.0.ebuild')
-rw-r--r--sys-apps/ack/ack-3.5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/ack/ack-3.5.0.ebuild b/sys-apps/ack/ack-3.5.0.ebuild
new file mode 100644
index 000000000000..fe8c7cc38c9b
--- /dev/null
+++ b/sys-apps/ack/ack-3.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=PETDANCE
+DIST_VERSION="v${PV}"
+inherit perl-module
+
+DESCRIPTION="ack is a tool like grep, optimized for programmers"
+HOMEPAGE="https://beyondgrep.com"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-perl/File-Next-1.180.0"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/IO-Tty )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.3.0-gentoo.patch )
+
+src_test() {
+ # Tests fail when run in parallel and if dev-perl/IO-Tty is installed
+ # which enables interactive tests that need to read from stdin. If IO-Tty
+ # is not installed the related tests are skipped.
+ MAKEOPTS+=" -j1" perl-module_src_test
+}