summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-09-20 19:14:32 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-09-20 19:14:48 +0200
commit665d2ab04b7f0583464b3f1c471853b27bc9bafe (patch)
tree24b515ec544287473cce040bfbe4b6e4e7cb7431 /sci-visualization
parentsys-process/bpytop-1.0.67: Version bump (diff)
downloadgentoo-665d2ab04b7f0583464b3f1c471853b27bc9bafe.tar.gz
gentoo-665d2ab04b7f0583464b3f1c471853b27bc9bafe.tar.bz2
gentoo-665d2ab04b7f0583464b3f1c471853b27bc9bafe.zip
sci-visualization/dash-table: bump 4.12.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/dash-table/Manifest1
-rw-r--r--sci-visualization/dash-table/dash-table-4.12.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-visualization/dash-table/Manifest b/sci-visualization/dash-table/Manifest
index fb78f350a952..33c5e9955d2e 100644
--- a/sci-visualization/dash-table/Manifest
+++ b/sci-visualization/dash-table/Manifest
@@ -1 +1,2 @@
DIST dash-table-4.11.3.tar.gz 9504642 BLAKE2B d48e1448caf19f555d8e8436de295d6999dc4caabd4e80d188ec9921278dc4e48b6631dbf4a572cd190210bb83f0a73986c0c93c269b931aeff1fd52e152e248 SHA512 580de0b92ae114cd65e5a2a85aa96a78cbf3364173135ddb29ac3d2edd3ad2aa7b526d447481f78379da2c2420ed9cc8d6a83836565ccac31249ecc4a94a3db5
+DIST dash-table-4.12.1.tar.gz 9773683 BLAKE2B 97f00d2d6e9619bdd794f2e478dd4ab2eeaa521b170cef3a546a86e53632099e917e38f99d7ddc91cc4eebcf6199c301128916e29a7afecb2138da667bf38d32 SHA512 f521204b571fb20951202713721fd9fdd790d72a8a2f8461f77244bf8dcd2fb88b88626b590a63f1d28938b30ec4610112c9d2d1b5089d59cdc5219c3e16b5aa
diff --git a/sci-visualization/dash-table/dash-table-4.12.1.ebuild b/sci-visualization/dash-table/dash-table-4.12.1.ebuild
new file mode 100644
index 000000000000..273b870d6b77
--- /dev/null
+++ b/sci-visualization/dash-table/dash-table-4.12.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="First-Class interactive DataTable for Dash"
+HOMEPAGE="https://plot.ly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+# Test execution depends on sci-visualization/dash being installed
+# but sci-visualization/dash depends on this
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needs percy - not available
+ rm -r tests/selenium || die
+
+ distutils-r1_python_prepare_all
+}