summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2017-03-19 15:41:21 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2017-03-19 16:07:41 +0300
commit65da54be8657f5e305429ebc2e218dfbd12cab09 (patch)
tree9384a036db63c637baf638ff218c24f678fd1490 /sci-physics
parentlicenses: Remove unused AMD license. (diff)
downloadgentoo-65da54be8657f5e305429ebc2e218dfbd12cab09.tar.gz
gentoo-65da54be8657f5e305429ebc2e218dfbd12cab09.tar.bz2
gentoo-65da54be8657f5e305429ebc2e218dfbd12cab09.zip
sci-physics/herwig: update to EAPI 6
- EAPI 6 bump - migrate from autotools-utils.eclass Package-Manager: Portage-2.3.4, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/herwig/herwig-6.5.21-r1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-physics/herwig/herwig-6.5.21-r1.ebuild b/sci-physics/herwig/herwig-6.5.21-r1.ebuild
new file mode 100644
index 000000000000..1a3dc54bf383
--- /dev/null
+++ b/sci-physics/herwig/herwig-6.5.21-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils fortran-2 versionator
+
+PV1=$(get_version_component_range 1 ${PV})
+PV2=$(get_version_component_range 2 ${PV})
+PV3=$(get_version_component_range 3 ${PV})
+MY_P=${PN}${PV1}${PV2}${PV3}
+MY_PINC="${PN^^}${PV1}${PV2}.INC"
+
+DESCRIPTION="High Energy Physics Event Generator"
+HOMEPAGE="http://www.hep.phy.cam.ac.uk/theory/webber/Herwig/"
+SRC_URI="
+ ${HOMEPAGE}/${MY_P}.f
+ ${HOMEPAGE}/${MY_P}.inc
+ ${HOMEPAGE}/${MY_PINC}
+ doc? ( ${HOMEPAGE}/hw65_manual.pdf )"
+
+LICENSE="all-rights-reserved"
+RESTRICT="mirror bindist"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="!sci-physics/cernlib-montecarlo[herwig]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}"/{"${MY_P}".f,"${MY_P}".inc,"${MY_PINC}"} "${S}" || die
+}
+
+src_prepare() {
+ sed -i \
+ -e "s/${PN}.*.inc/${MY_P}.inc/" \
+ ${MY_PINC} || die
+ cat > configure.ac <<-EOF || die
+ AC_INIT(${PN},${PV})
+ AM_INIT_AUTOMAKE
+ AC_PROG_F77
+ AC_PROG_LIBTOOL
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ cat > Makefile.am <<-EOF || die
+ lib_LTLIBRARIES = lib${PN}.la
+ lib${PN}_la_SOURCES = ${MY_P}.f
+ include_HEADERS = \
+ ${MY_PINC} \
+ ${MY_P}.inc
+
+ EOF
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use doc && dodoc "${DISTDIR}"/hw65_manual.pdf
+}