summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-18 10:38:42 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-18 13:40:29 -0600
commit271a9f98674f3e5d3f989553e2d3eb0df445c800 (patch)
tree96c17358a1e9670478adb9f1dfcac9af10ce546b /sci-physics/espresso
parentgames-action/powermanga: remove deprecated games eclass (diff)
downloadgentoo-271a9f98674f3e5d3f989553e2d3eb0df445c800.tar.gz
gentoo-271a9f98674f3e5d3f989553e2d3eb0df445c800.tar.bz2
gentoo-271a9f98674f3e5d3f989553e2d3eb0df445c800.zip
sci-physics/espresso: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-physics/espresso')
-rw-r--r--sci-physics/espresso/Manifest1
-rw-r--r--sci-physics/espresso/espresso-3.3.1.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/sci-physics/espresso/Manifest b/sci-physics/espresso/Manifest
index 638d0ca97c67..73ae97cdf72d 100644
--- a/sci-physics/espresso/Manifest
+++ b/sci-physics/espresso/Manifest
@@ -1 +1,2 @@
DIST espresso-3.3.0.tar.gz 18952622 SHA256 64ea2684e4fc0d31c11969e49ec74c25138b4f74686f67b93c7e1103833ff08f SHA512 90edbbdc8d7f7247b5179fce0fad796a9488f82a1754519918c6588c932050675397d36e0167aae770db9803b6c22f7d14d23c04cf307d10802afd3d5d5edc20 WHIRLPOOL 3e9547f2da6676edf3de415fa848301f2959c3dfeef1c3f461b4e1eb202224ead7635748b47d42edb9f661dc5d672f38168e15ab6c55a9c9d7f102ae11f8574e
+DIST espresso-3.3.1.tar.gz 18986557 SHA256 8576fc1fe59e04dec4fa0d354b7ec52365622860099624f36bddbb2b472c0c70 SHA512 3fc6e681e625f2cf98ac0aa3b1c16fbe17b9f9aa8f79f2e89926501cbb68621d171d6c6a22f42f9f60298ee31520ca712ace57d57738d2cf76f7ae2f7c0436b1 WHIRLPOOL 7075cbb8fba944cda8290a3f27650fcdd2b466495c6d4697ae3074c60ded86e08ea4ea0d9336c8ca859f7b3303cd496dba2972c9c8205a7b3cafbe36fcfc8a40
diff --git a/sci-physics/espresso/espresso-3.3.1.ebuild b/sci-physics/espresso/espresso-3.3.1.ebuild
new file mode 100644
index 000000000000..749540599a1f
--- /dev/null
+++ b/sci-physics/espresso/espresso-3.3.1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 savedconfig
+
+DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
+HOMEPAGE="http://espressomd.org"
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/espressomd/espresso.git https://github.com/espressomd/espresso.git"
+ EGIT_BRANCH="master"
+ inherit autotools git-r3
+ KEYWORDS=""
+else
+ SRC_URI="mirror://nongnu/${PN}md/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="X cuda doc examples +fftw mpi packages python test -tk"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tk? ( X )"
+
+RESTRICT="tk? ( test )"
+
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ dev-lang/tcl:0=
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+ fftw? ( sci-libs/fftw:3.0 )
+ mpi? ( virtual/mpi )
+ packages? ( dev-tcltk/tcllib )
+ tk? ( >=dev-lang/tk-8.4.18-r1:0= )
+ X? ( x11-libs/libX11 )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base )"
+
+DOCS=( AUTHORS NEWS README ChangeLog )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+ default
+}
+
+src_configure() {
+ [[ ${PV} = 9999 ]] && eautoreconf
+ CXX=$(usex mpi "mpic++" "$(tc-getCXX)") econf \
+ $(use_with fftw) \
+ $(use_with cuda) \
+ $(use_with python python-interface) \
+ $(use_with mpi) \
+ $(use_with tk) \
+ $(use_with X x)
+ restore_config myconfig.hpp
+}
+
+src_compile() {
+ default
+ use doc && emake doxygen
+ [[ ${PV} = 9999 ]] && use doc && emake ug dg tutorials
+}
+
+src_install() {
+ local i
+
+ default
+
+ insinto /usr/share/${PN}
+ doins myconfig-sample.hpp
+
+ save_config src/core/myconfig-final.hpp
+
+ if use doc; then
+ if [[ ${PV} = 9999 ]] ; then
+ newdoc doc/dg/dg.pdf developer_guide.pdf
+ newdoc doc/ug/ug.pdf user_guide.pdf
+ for i in doc/tutorials/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ else
+ newdoc "${S}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${S}"/doc/tutorials/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ fi
+ dodoc -r doc/doxygen/html
+ fi
+
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins -r samples/*
+ fi
+
+ if use packages; then
+ insinto /usr/share/${PN}/packages
+ doins -r packages/*
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Please read and cite:"
+ elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
+ elog "http://dx.doi.org/10.1016/j.cpc.2005.10.005"
+ echo
+ elog "If you need more features, change"
+ elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
+ elog "and reemerge with USE=savedconfig"
+ echo
+ elog "For a full feature list see:"
+ elog "/usr/share/${PN}/myconfig-sample.h"
+ echo
+}