summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-23 14:05:50 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-23 14:11:22 +0100
commit8fc9b291e5fee2655e998711dd7fe2f40b224139 (patch)
treea395b1ee65443640c0012862a3f0a561a5ff1184 /sci-misc
parentnet-im/rocketchat-desktop-bin: drop version 3.7.0 (diff)
downloadgentoo-8fc9b291e5fee2655e998711dd7fe2f40b224139.tar.gz
gentoo-8fc9b291e5fee2655e998711dd7fe2f40b224139.tar.bz2
gentoo-8fc9b291e5fee2655e998711dd7fe2f40b224139.zip
sci-misc/jupyterlab-desktop-bin: add version 3.2.5.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.5.2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 2c25dbad3da5..8d457f7d0fdc 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST jupyterlab-desktop-bin-3.2.4.3.rpm 269019824 BLAKE2B cc4acde522b3cab06e1d4b26ed21352cb20396e766c71da889fb19fae52af0df7c8acd4e9b91083ab944995fdc2f3acf3af28c7320e0da951505ea75e2c70b63 SHA512 6eb5220e149cd2f61cbaf35e377bdd02fefa292eb0145936da6d7b875f68779a47f5a99be12bf57b44840f6b5bdfd3e9923bf0947cbe3c2e155cd5f5e2c64317
+DIST jupyterlab-desktop-bin-3.2.5.2.rpm 269694928 BLAKE2B c92a46c273d4b3edfedf9392ff65813366317003607ab27c359b995cd896591454fbf8460b6ce22d717e0d28ba2c7800bf346f18c23dd758e58b4c329b3164f1 SHA512 7720c727a2a027f0f45072c92186b9fe7ea911aa2168100995e79feac0e248e9d3dde2f2fadcd43b749c394f604f09a53db81eebf26fdac5396bba81f6c75904
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.5.2.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.5.2.ebuild
new file mode 100644
index 000000000000..8d7e5705e20f
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.5.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/jupyterlab
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/JupyterLab/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+ # add convenience symlink to launch from cli
+ dosym ../JupyterLab/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}