summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-03 22:31:51 -0500
committerSam James <sam@gentoo.org>2024-03-04 04:14:11 +0000
commit83e5cbb7ba3a7d3973cca29465fac8b777f96cc3 (patch)
tree42a415a457950e2f3f82c1280f1eb1234030f452 /sci-mathematics
parentdev-libs/libgnt: mark as LTO-unsafe (diff)
downloadgentoo-83e5cbb7ba3a7d3973cca29465fac8b777f96cc3.tar.gz
gentoo-83e5cbb7ba3a7d3973cca29465fac8b777f96cc3.tar.bz2
gentoo-83e5cbb7ba3a7d3973cca29465fac8b777f96cc3.zip
sci-mathematics/z3: mark as LTO-unsafe, strict-aliasing unsafe
The strict-aliasing violation happens only in a test program. However, that does mean we cannot test that z3 works when built with LTO... Closes: https://bugs.gentoo.org/879327 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/z3/z3-4.12.5.ebuild14
-rw-r--r--sci-mathematics/z3/z3-4.12.6.ebuild14
2 files changed, 26 insertions, 2 deletions
diff --git a/sci-mathematics/z3/z3-4.12.5.ebuild b/sci-mathematics/z3/z3-4.12.5.ebuild
index 646bf2695514..64ffaff192f5 100644
--- a/sci-mathematics/z3/z3-4.12.5.ebuild
+++ b/sci-mathematics/z3/z3-4.12.5.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib java-pkg-opt-2 python-single-r1
+inherit cmake-multilib flag-o-matic java-pkg-opt-2 python-single-r1
DESCRIPTION="An efficient theorem prover"
HOMEPAGE="https://github.com/Z3Prover/z3/"
@@ -37,6 +37,18 @@ src_prepare() {
java-pkg-opt-2_src_prepare
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/879327
+ # https://github.com/Z3Prover/z3/issues/7143
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ cmake-multilib_src_configure
+}
+
multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
diff --git a/sci-mathematics/z3/z3-4.12.6.ebuild b/sci-mathematics/z3/z3-4.12.6.ebuild
index 951e88b0875b..f7df502b3d41 100644
--- a/sci-mathematics/z3/z3-4.12.6.ebuild
+++ b/sci-mathematics/z3/z3-4.12.6.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib java-pkg-opt-2 python-single-r1
+inherit cmake-multilib flag-o-matic java-pkg-opt-2 python-single-r1
DESCRIPTION="An efficient theorem prover"
HOMEPAGE="https://github.com/Z3Prover/z3/"
@@ -37,6 +37,18 @@ src_prepare() {
java-pkg-opt-2_src_prepare
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/879327
+ # https://github.com/Z3Prover/z3/issues/7143
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ cmake-multilib_src_configure
+}
+
multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"