summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2017-11-27 19:03:39 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-30 15:45:48 +0100
commit1bfb1137cf241f1ae7fbaba01a1f7a957eedb41a (patch)
treedb51691f52c803c0f462099ce9f772d2639fd0b5 /sci-mathematics
parentdev-lisp/clozurecl: bump to 1.11.5 (diff)
downloadgentoo-1bfb1137cf241f1ae7fbaba01a1f7a957eedb41a.tar.gz
gentoo-1bfb1137cf241f1ae7fbaba01a1f7a957eedb41a.tar.bz2
gentoo-1bfb1137cf241f1ae7fbaba01a1f7a957eedb41a.zip
sci-mathematics/gimps: version bump to 29.4.5.
Closes: https://bugs.gentoo.org/638452 Closes: https://github.com/gentoo/gentoo/pull/6325
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gimps/Manifest2
-rw-r--r--sci-mathematics/gimps/gimps-29.4.5.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index 3fb857d5a133..16dbc7f87e87 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -1,2 +1,4 @@
DIST p95v2810.linux32.tar.gz 4610763 SHA256 ef9b90e9b82c6710af53471eb18328b80cc46f0a41f137bc224efca0ed570d95 SHA512 ac2e0f2e1b557b71084027a5bd7cafeb350df3ee9edf347766d34d4a607034827494eb15dae30404da33f8c9f279a85e033cf845800868f4c51087a35b49c521 WHIRLPOOL f3609de0845308811e09f4a2159709ea69b070f20fe3cc9e71d0bd9d98fff579e0763b8f52cfcc65339dfa3723f622bd97334ae3daf975ad0a9898f803d6c70a
DIST p95v2810.linux64.tar.gz 5707219 SHA256 ed5a8b94fdd65436e98e57ea0838035fd44c62492009d00f5fba508cb85481c7 SHA512 c4fd692df3018e5e73ba6095de5ed394f36d5c89dd81c2c7f2c74a4ce3184b22176dc13b8b59e4f42c1781e911107dc12224cfcddef882535931319ec93120f1 WHIRLPOOL 91c1f657df196b8eb27b88727e35cee831a98cbe99d3a88834ba868c4b491144fc4efb66d389f76203481f252b3ef9cc0c2241aa3d153abc1857f09cf3971ac7
+DIST p95v294b5.linux32.tar.gz 5455113 SHA256 218e1b6008163a811a26c786be90619649dc9818fd974b0a0a81411db5e8d8b6 SHA512 e8a0061c363333a7c36eb24ef72e9293903404563d04cdcad6432e63d25d8b85e1f0c8e8a46d9795a204830a01031024f82362bcedec4fcec954899e4d6e7127 WHIRLPOOL 949e462fe687bff5b66f32e320b491bc0eea2ee1ceb9b1b55cc6440343cc6503aceb567a86df2dec58144036ae9ecea6590bb5d5f810ae7da217a5d7cc86c02e
+DIST p95v294b5.linux64.tar.gz 6244650 SHA256 6c389f981886b4c3df1544b6cc3945df807497460193c5bb220f2b523a24ff89 SHA512 e315ea226649df2135895a1206e5845fd05587ad190b676228e5e1cfca04a11b698f1a7d5b8e7c96b0cd174ce3dbeb6000240b67a3f0f90572f3bf15166020e5 WHIRLPOOL 9dc54bb78a3a9d1e7374bff02f99ca1da607011d90f8b5dfb095cc50d17a8e075cb0fd8f2b51fadfb20acae84fc782c9a0a2d000225c7760f25e41f149233297
diff --git a/sci-mathematics/gimps/gimps-29.4.5.ebuild b/sci-mathematics/gimps/gimps-29.4.5.ebuild
new file mode 100644
index 000000000000..a4815dbb80ff
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-29.4.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit pax-utils systemd readme.gentoo-r1 versionator
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(replace_version_separator 2 'b' )
+
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${MY_PV/./}.linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/p95v${MY_PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64 ~x86"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}" || die
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}