summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-10-03 14:39:02 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-10-03 14:53:55 +0200
commite9493ba2c26c1af946fd851d111893f8d8664eed (patch)
treee248b9f610825d733b9d01c155fe929f3578f745 /sci-libs
parentdev-python/huawei-lte-api: remove old (diff)
downloadgentoo-e9493ba2c26c1af946fd851d111893f8d8664eed.tar.gz
gentoo-e9493ba2c26c1af946fd851d111893f8d8664eed.tar.bz2
gentoo-e9493ba2c26c1af946fd851d111893f8d8664eed.zip
sci-libs/huggingface_hub: add 0.24.7
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/huggingface_hub/Manifest1
-rw-r--r--sci-libs/huggingface_hub/huggingface_hub-0.24.7.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/huggingface_hub/Manifest b/sci-libs/huggingface_hub/Manifest
index 3c604dceedeb..bcef560c8550 100644
--- a/sci-libs/huggingface_hub/Manifest
+++ b/sci-libs/huggingface_hub/Manifest
@@ -1,2 +1,3 @@
DIST huggingface_hub-0.20.3.gh.tar.gz 3276706 BLAKE2B 2dd9fe557db4e88481bcc675dd1d6d35ec26244b723ea6bed01555e20fcba1dfa269ab3a1de9c8afa21d25b57550f822ca05bfd9d54db7e7b4740116c5ea3469 SHA512 b6eb9875da4d3c0b7190e61beee14ba913fb0f967967a70a6a65e5d42881e06710fb132e471c6e9b0ea1cd0987b2ebd31754d90aded3a84f4ddcfb0a0efe2f21
DIST huggingface_hub-0.21.4.gh.tar.gz 3565936 BLAKE2B 8aac3ca36369040fe8f7b628cc07a5d890b845d3bfec0dcf6cf7fc477c5c30d680c2dc0531d92c5e814d86f098fad87c80113f37719b41a1eac696f6abd82372 SHA512 886e553c474b59a47d1c5e04c7429ca5c1eb6bcb88a0f7ed6f1396d43c3195bb1f376093384f40497f18fb2220e3e0d9c4b7787c009b84d1d38b6d706307f67f
+DIST huggingface_hub-0.24.7.gh.tar.gz 4009372 BLAKE2B e1a949dc204af152538bb95e226c3e1fa9faaf0b77a49c6a5adee9d751c0b1344c9c76670baf840fe7eb04e8a2dd8816fcac7e143e26c6fe589bb9e4325120f3 SHA512 e944e5091121197ee78f4b199795fad3f984fd7177103357303010b412ff3e88c613efe1c8fc328f602475f3e4d747d8262e0675ea9ff831310875bb70e5fef9
diff --git a/sci-libs/huggingface_hub/huggingface_hub-0.24.7.ebuild b/sci-libs/huggingface_hub/huggingface_hub-0.24.7.ebuild
new file mode 100644
index 000000000000..e15ad7ee698e
--- /dev/null
+++ b/sci-libs/huggingface_hub/huggingface_hub-0.24.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="a client library to interact with the Hugging Face Hub"
+HOMEPAGE="
+ https://pypi.org/project/huggingface_hub/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" #Several modules not yet packaged
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest