summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-11-01 21:49:01 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-11-01 21:50:13 +0100
commitd23846dad7175a4f631e96eb4eecd503151aa3c9 (patch)
tree90e76f6476506e6395dd09fd704647d66ea0e03e /sci-libs
parentxfce-extra/xfce4-notifyd: Stabilize 0.9.2 amd64, #916669 (diff)
downloadgentoo-d23846dad7175a4f631e96eb4eecd503151aa3c9.tar.gz
gentoo-d23846dad7175a4f631e96eb4eecd503151aa3c9.tar.bz2
gentoo-d23846dad7175a4f631e96eb4eecd503151aa3c9.zip
sci-libs/onnx: install python modules
Closes: https://bugs.gentoo.org/915843 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/onnx-1.14.0-r1.ebuild32
-rw-r--r--sci-libs/onnx/onnx-1.14.0-r2.ebuild59
2 files changed, 59 insertions, 32 deletions
diff --git a/sci-libs/onnx/onnx-1.14.0-r1.ebuild b/sci-libs/onnx/onnx-1.14.0-r1.ebuild
deleted file mode 100644
index bed797b68a21..000000000000
--- a/sci-libs/onnx/onnx-1.14.0-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-inherit python-any-r1 cmake
-
-DESCRIPTION="Open Neural Network Exchange (ONNX)"
-HOMEPAGE="https://github.com/onnx/onnx"
-SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-RESTRICT="test"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-libs/protobuf:="
-BDEPEND="
- ${PYTHON_DEPS}
-"
-
-PATCHES=( "${FILESDIR}"/${P}-cxx_14.patch )
-
-src_configure() {
- local mycmakeargs=(
- -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
- )
- cmake_src_configure
-}
diff --git a/sci-libs/onnx/onnx-1.14.0-r2.ebuild b/sci-libs/onnx/onnx-1.14.0-r2.ebuild
new file mode 100644
index 000000000000..7fcd28a9355b
--- /dev/null
+++ b/sci-libs/onnx/onnx-1.14.0-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_OPTIONAL=1
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 cmake
+
+DESCRIPTION="Open Neural Network Exchange (ONNX)"
+HOMEPAGE="https://github.com/onnx/onnx"
+SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="python"
+RESTRICT="test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ )
+ dev-libs/protobuf:=
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="python? (
+ ${DISTUTILS_DEPS}
+)"
+
+PATCHES=( "${FILESDIR}"/${P}-cxx_14.patch )
+
+src_prepare() {
+ cmake_src_prepare
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ cmake_src_install
+ use python && distutils-r1_src_install
+}