summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2024-01-17 21:38:52 -0500
committerRick Farina <zerochaos@gentoo.org>2024-01-17 21:39:13 -0500
commit6baa55cb69a6ac0e11b202e449de030e854d685e (patch)
treef780e0e3ccde1a2ea0124eda7eed1ab867e5f204 /sci-libs
parentsci-libs/volk: add 3.1.0 (diff)
downloadgentoo-6baa55cb69a6ac0e11b202e449de030e854d685e.tar.gz
gentoo-6baa55cb69a6ac0e11b202e449de030e854d685e.tar.bz2
gentoo-6baa55cb69a6ac0e11b202e449de030e854d685e.zip
sci-libs/volk: drop 3.0.0-r1
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/volk/Manifest1
-rw-r--r--sci-libs/volk/volk-3.0.0-r1.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/sci-libs/volk/Manifest b/sci-libs/volk/Manifest
index 1e3ed7081c7e..34a3676eaad0 100644
--- a/sci-libs/volk/Manifest
+++ b/sci-libs/volk/Manifest
@@ -1,2 +1 @@
-DIST volk-3.0.0.tar.xz 394044 BLAKE2B 04e832916375610571387db521348df2a37f5460500c4bd6d223dd6af9c0a207f3b22c599fccbf9bd51b8a87ed90cb5239512c19fc6ddd02320b7aa27c3be588 SHA512 5d1ff90f28ec6ef2d21370d74025139ccc9872e5a477b271ffe6662725b7705203715ea4ffc430554ec2fec56e8d9b40a945e75186761995d3075218e1f16313
DIST volk-3.1.0.tar.xz 420088 BLAKE2B 709c3561675b0f71a1400d7b9332aa18c6d2ae848c993914cb40484890f631bde48da12ab9756be38cca9fbb20d0d851cb40ff5bfe3722ff72cd0b4daff1b11d SHA512 0c39c06e5121782461c0ea2c84402c84f9609a2a09ce7218e976472081d09531746ea1cde767f329a69d72d51cf5715bf7f2df1b26a8d8ddd1694e8239f5ff21
diff --git a/sci-libs/volk/volk-3.0.0-r1.ebuild b/sci-libs/volk/volk-3.0.0-r1.ebuild
deleted file mode 100644
index 39eb8873bba8..000000000000
--- a/sci-libs/volk/volk-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..12} )
-
-#https://github.com/gnuradio/volk/issues/383
-CMAKE_BUILD_TYPE="None"
-inherit cmake python-single-r1
-
-DESCRIPTION="vector optimized library of kernels"
-HOMEPAGE="http://libvolk.org"
-SRC_URI="https://github.com/gnuradio/volk/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~riscv ~x86"
-IUSE="orc test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
- orc? ( dev-lang/orc )"
-DEPEND="${RDEPEND}
- $(python_gen_cond_dep 'dev-python/mako[${PYTHON_USEDEP}]')"
-
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_ORC=$(usex orc)
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DENABLE_TESTING="$(usex test)"
- -DENABLE_PROFILING=OFF
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- # Remove stray python files generated by the build system
- find "${ED}" -name '*.pyc' -exec rm -f {} \; || die
- find "${ED}" -name '*.pyo' -exec rm -f {} \; || die
- # https://github.com/gnuradio/volk/issues/626
- rm -f "${ED}/usr/bin/list_cpu_features"
- rm -rf "${ED}/usr/include/cpu_features"
- rm -rf "${ED}/usr/$(get_libdir)/cmake/CpuFeatures"
- rm -rf "${ED}/usr/lib64/libcpu_features.a"
- python_optimize
-}
-
-src_test() {
- local myctestargs=(
- -E "(check_lgpl)"
- )
- cmake_src_test
-}