summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-05-25 22:45:42 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-05-25 22:45:58 +0200
commitafde2e0ab793a71519de0b9d76be87da10a5df3d (patch)
tree2dbe736c874c9e0d9ea9ab2a3cc3052b88227b95 /sci-libs/transformers
parentprofiles/arches.desc: drop removed keywords (diff)
downloadgentoo-afde2e0ab793a71519de0b9d76be87da10a5df3d.tar.gz
gentoo-afde2e0ab793a71519de0b9d76be87da10a5df3d.tar.bz2
gentoo-afde2e0ab793a71519de0b9d76be87da10a5df3d.zip
sci-libs/transformers: add 4.29.2
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/transformers')
-rw-r--r--sci-libs/transformers/Manifest1
-rw-r--r--sci-libs/transformers/transformers-4.29.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/transformers/Manifest b/sci-libs/transformers/Manifest
index 8ea1ec385306..b563df71ecac 100644
--- a/sci-libs/transformers/Manifest
+++ b/sci-libs/transformers/Manifest
@@ -1 +1,2 @@
DIST transformers-4.27.4.gh.tar.gz 13210647 BLAKE2B acf5c81ceaaa2f156fc90b2284a6e2d4369742705c14d777c12e94a23961f3ed7cdc8e3cf8a4b962600b59f529862e6546f3d212e1ae1c44b7f76d8a10cbea75 SHA512 8b84a74c473c514314c3c4a422f8c03118575add3499ca280b7259bad72f8f8a6a7a51dc12162963c033b6a65c8914cca011b7bf6343781c5ed35154ea7adaf4
+DIST transformers-4.29.2.gh.tar.gz 13775570 BLAKE2B 01d64001e0ca8c06247f35391fe79edd59b3c02e1ec5fe0cac6ca3a4028633f6deba7f50762b2b688acc524658e25b8ecf4b6618ab6ff12d5737fd7c1864ada8 SHA512 2526f9d2de12e3f73899fb6ab5390884f9884a05ba492235bc95897f99bb45616ed737c87b9b8ac83550dd90b68025adf63a1f95c22a2e708528889215c8299c
diff --git a/sci-libs/transformers/transformers-4.29.2.ebuild b/sci-libs/transformers/transformers-4.29.2.ebuild
new file mode 100644
index 000000000000..1ec34e499712
--- /dev/null
+++ b/sci-libs/transformers/transformers-4.29.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="State-of-the-art Machine Learning for JAX, PyTorch and TensorFlow"
+HOMEPAGE="
+ https://pypi.org/project/transformers/
+ https://huggingface.co/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+#RESTRICT="test" # Need dataset module, not yet packaged
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ sci-libs/huggingface_hub[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sci-libs/tokenizers[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest