summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-26 00:47:18 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-26 09:12:42 -0400
commit5f53e79a02caf41a76d6987ad678003bd042fac4 (patch)
tree11a29e21b34ff1f0e8145be49a955fd9c93a0fb1 /sci-libs/spqr
parentapp-arch/upx-bin: drop 4.2.3 (diff)
downloadgentoo-5f53e79a02caf41a76d6987ad678003bd042fac4.tar.gz
gentoo-5f53e79a02caf41a76d6987ad678003bd042fac4.tar.bz2
gentoo-5f53e79a02caf41a76d6987ad678003bd042fac4.zip
sci-libs/spqr: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sci-libs/spqr')
-rw-r--r--sci-libs/spqr/spqr-2.0.9-r3.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sci-libs/spqr/spqr-2.0.9-r3.ebuild b/sci-libs/spqr/spqr-2.0.9-r3.ebuild
index b63bdbe966ea..a7499f3bf790 100644
--- a/sci-libs/spqr/spqr-2.0.9-r3.ebuild
+++ b/sci-libs/spqr/spqr-2.0.9-r3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit libtool
+
DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
@@ -25,6 +27,11 @@ DEPEND="
tbb? ( <dev-cpp/tbb-2021:= )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf \
--disable-static \