summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2021-08-25 21:51:30 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-08-27 19:53:48 +0800
commit53a7ade3df5481b63bdad1da958080d3c298c782 (patch)
tree94c2fab24d3d925e018fc4e3c5851e282dd34785 /sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch
parentsci-libs/rocBLAS: Next generation BLAS implementation for ROCm (diff)
downloadgentoo-53a7ade3df5481b63bdad1da958080d3c298c782.tar.gz
gentoo-53a7ade3df5481b63bdad1da958080d3c298c782.tar.bz2
gentoo-53a7ade3df5481b63bdad1da958080d3c298c782.zip
sci-libs/rocSPARSE: bump version to 4.3.0
Enable test and benchmark, although with minor issues. Closes: https://github.com/gentoo/gentoo/pull/22112/ Bug: https://github.com/ROCmSoftwarePlatform/rocSPARSE/issues/227 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch')
-rw-r--r--sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch b/sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch
new file mode 100644
index 000000000000..2f19725a6e10
--- /dev/null
+++ b/sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch
@@ -0,0 +1,36 @@
+Don't let cmake handle test data download, unpack and convert
+
+--- orig/clients/tests/CMakeLists.txt
++++ rocSPARSE-rocm-4.3.0/clients/tests/CMakeLists.txt
+@@ -23,31 +23,6 @@
+
+ find_package(GTest 1.10.0 REQUIRED)
+
+-#
+-# Client matrices.
+-#
+-if(NOT EXISTS "${CMAKE_MATRICES_DIR}")
+- #
+- # Download.
+- #
+- set(CMAKE_MATRICES_DIR ${PROJECT_BINARY_DIR}/matrices CACHE STRING "Matrices directory.")
+-
+- if(NOT TARGET rocsparse)
+- set(CONVERT ${CMAKE_SOURCE_DIR}/../deps/convert CACHE STRING "Convert tool mtx2csr.")
+- include(${CMAKE_SOURCE_DIR}/../cmake/ClientMatrices.cmake)
+- else()
+- set(CONVERT ${CMAKE_SOURCE_DIR}/deps/convert CACHE STRING "Convert tool mtx2csr.")
+- include(${CMAKE_SOURCE_DIR}/cmake/ClientMatrices.cmake)
+- endif()
+-
+-else()
+-
+- #
+- # Copy.
+- #
+- execute_process(COMMAND cp -r ${CMAKE_MATRICES_DIR} ${PROJECT_BINARY_DIR}/matrices)
+-
+-endif()
+
+ set(ROCSPARSE_TEST_SOURCES
+ test_axpby.cpp