summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-06-19 13:12:54 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-06-19 13:26:34 -0500
commit6a50020bc6833ba5dd8a6663dc84a461b104cd43 (patch)
treee33f8d6882001714681e7875c0996b22fbd47d1f /sci-libs/p4est
parentsci-libs/libsc: drop 9999 (diff)
downloadgentoo-6a50020bc6833ba5dd8a6663dc84a461b104cd43.tar.gz
gentoo-6a50020bc6833ba5dd8a6663dc84a461b104cd43.tar.bz2
gentoo-6a50020bc6833ba5dd8a6663dc84a461b104cd43.zip
sci-libs/p4est: drop 9999
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/p4est')
-rw-r--r--sci-libs/p4est/p4est-9999.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/sci-libs/p4est/p4est-9999.ebuild b/sci-libs/p4est/p4est-9999.ebuild
deleted file mode 100644
index 41605b7be0f7..000000000000
--- a/sci-libs/p4est/p4est-9999.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="Scalable Algorithms for Parallel Adaptive Mesh Refinement on Forests of Octrees"
-HOMEPAGE="http://www.p4est.org/"
-
-LIBSC_VERSION="2.8.3"
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/cburstedde/${PN}.git"
- EGIT_BRANCH="develop"
- SRC_URI=""
-else
- SRC_URI="https://github.com/cburstedde/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-
-# TODO petsc
-IUSE="debug doc examples mpi openmp threads +vtk-binary"
-
-RDEPEND="
- ~sci-libs/libsc-${LIBSC_VERSION}[mpi=,openmp=,threads=]
- sys-apps/util-linux
- virtual/blas
- virtual/lapack
- mpi? ( virtual/mpi[romio] )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.8-fix_build_system.patch
- "${FILESDIR}"/${P}-set_version.patch
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- local mycmakeargs=(
- -Dmpi="$(usex mpi)"
- -Dopenmp="$(usex openmp)"
- -Dlibrary_reldir="$(get_libdir)"
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- rm "${ED}"/usr/lib/cmake/Modules/FindSC.cmake || die "rm failed"
- mv "${ED}"/usr/share/docs/P4EST/* "${ED}"/usr/share/doc/${P}/ || die "mv failed"
- rm -r "${ED}"/usr/share/docs || die "rm failed"
-}