summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-08-04 19:40:39 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-04 19:40:39 +0200
commit1230fc12333f51a3e3b7e10db361940aec5ddcda (patch)
treeb2cdb7aed2b8ffdbfac23470cdd32eb30291dfe5 /sci-libs/p4est
parentsci-libs/libsc: remove USE=static-libs (diff)
downloadgentoo-1230fc12333f51a3e3b7e10db361940aec5ddcda.tar.gz
gentoo-1230fc12333f51a3e3b7e10db361940aec5ddcda.tar.bz2
gentoo-1230fc12333f51a3e3b7e10db361940aec5ddcda.zip
sci-libs/p4est: drop 2.2-r100
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/p4est')
-rw-r--r--sci-libs/p4est/Manifest2
-rw-r--r--sci-libs/p4est/p4est-2.2-r100.ebuild120
2 files changed, 0 insertions, 122 deletions
diff --git a/sci-libs/p4est/Manifest b/sci-libs/p4est/Manifest
index 9140b29444aa..53d047ba796d 100644
--- a/sci-libs/p4est/Manifest
+++ b/sci-libs/p4est/Manifest
@@ -1,4 +1,2 @@
-DIST libsc-2.2.tar.gz 311542 BLAKE2B 0879be69208f0964d73cc297a64b158ad88344e876a90dd4bd39c80fc0cf8237f4551cb684dee36e08068fa04644b887ec56230335a9984363055c1248aa6185 SHA512 97953794fdeb985bedb1dc9378f10ed4824446c63762d7813aced3309c2d6b27368c91fecb22587dccdf8b3b42aaaba9e782b739086cf542570360795897ac14
DIST libsc-2.3.1.tar.gz 344456 BLAKE2B cee44d07372162aecc8104257d1c5d4935d60030ceae4041ae4c5110f491b48b7709c55af0286b2a1fc5df2d7883b2ab4499c3884162b779fb9aaa86fbc5822c SHA512 02e160ad6fb4e674a9de2a41cfef6727d470a17c184e7b0310fe3e39f1112f4c643ca35a62377562caf1e8cc753cd5c0f5f996fba24b115498b01d16c140080a
-DIST p4est-2.2.tar.gz 1323529 BLAKE2B 262cb8d1ceff1329a71fd302b12c1650e9c099e72a9a93b4abef5822b16a28af0ee1ce9a338c524c2077d4bff83e607e9346f5bb1c660aa9afa8241bb631a637 SHA512 8475e0b6ab1225b22e7538c9c9b227f9aef86f78adf0706065a05f4682618f8f5d3878c18c11b8b13b3912e1de95f40b0ef5f5f5d217c02196993ac07f085299
DIST p4est-2.3.1.tar.gz 2623681 BLAKE2B 426f15d27dd376b918e197adc46a8ef5555bd4765f53d7c98bc8f9b58e0a27125d38808503fd1c545e428e845635e2499ba27df22a989ed619ce264417d02908 SHA512 c691b39d140c2714a813dc45f721cf21a1e0f5d1a264a3d5733b09ec90cc3f8bcc9e5d799e41e91d2b994490c811287f8177bf6d7890ea4cd1cdfecb95cdbf23
diff --git a/sci-libs/p4est/p4est-2.2-r100.ebuild b/sci-libs/p4est/p4est-2.2-r100.ebuild
deleted file mode 100644
index ee878cbfc3ee..000000000000
--- a/sci-libs/p4est/p4est-2.2-r100.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..2} )
-
-# The build system currently fails with everything newer than 1.11.
-WANT_AUTOMAKE=1.11
-
-inherit autotools lua-single toolchain-funcs
-
-DESCRIPTION="Scalable Algorithms for Parallel Adaptive Mesh Refinement on Forests of Octrees"
-HOMEPAGE="http://www.p4est.org/"
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/cburstedde/${PN}.git"
- EGIT_BRANCH="develop"
- SRC_URI=""
-else
- SRC_URI="
- https://github.com/cburstedde/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/cburstedde/libsc/archive/v${PV}.tar.gz -> libsc-${PV}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-
-# TODO petsc
-IUSE="debug doc examples mpi openmp romio static-libs threads +vtk-binary"
-REQUIRED_USE="${LUA_REQUIRED_USE}
- romio? ( mpi )"
-
-RDEPEND="${LUA_DEPS}
- ~sci-libs/libsc-${PV}[${LUA_SINGLE_USEDEP},mpi=,openmp=,romio=,static-libs=,threads=]
- sys-apps/util-linux
- virtual/blas
- virtual/lapack
- mpi? ( virtual/mpi[romio=] )"
-
-DEPEND="
- ${RDEPEND}
- sys-devel/automake:1.11
- virtual/pkgconfig"
-
-DOCS=( AUTHORS NEWS README )
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != "binary" ]] && use openmp; then
- tc-has-openmp || \
- die "Please select an openmp capable compiler like gcc[openmp]"
- fi
-}
-
-src_prepare() {
- default
-
- # Inject libsc to get all parts of the build system...
- if ! [[ ${PV} = *9999* ]]; then
- rmdir "${S}/sc" || die "rmdir failed"
- mv "${WORKDIR}/libsc-${PV}" "${S}/sc" || die "mv failed"
- fi
-
- # Inject a version number into the build system
- echo "${PV}" > ${S}/.tarball-version
-
- AT_M4DIR="${WORKDIR}/${P}/config ${WORKDIR}/${P}/sc/config"
- eautoreconf
-
- sed -i \
- "s/P4EST_SC_DIR\/etc/P4EST_SC_DIR\/share\/libsc/" \
- "${S}"/configure || die "sed failed"
-
- sed -i \
- "s#lib/libsc\.la#$(get_libdir)/libsc\.so#" \
- "${S}"/configure || die "sed failed"
-}
-
-src_configure() {
- # avoid underlinkage
- LDFLAGS="${LDFLAGS} -lsc"
-
- local myeconfargs=(
- $(use_enable debug)
- $(use_enable mpi)
- $(use_enable openmp)
- $(use_enable romio mpiio)
- $(use_enable static-libs static)
- $(use_enable threads pthread)
- $(use_enable vtk-binary)
- --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
- --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
- --with-sc="${EPREFIX}/usr"
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- use doc && dodoc -r doc/*
-
- if use examples
- then
- docinto examples
- dodoc -r example/*
- docompress -x /usr/share/doc/${PF}/examples
- else
- # Remove compiled example binaries in case of -examples:
- rm -r "${ED}"/usr/bin || die "rm failed"
- fi
-
- # Fix wrong installation paths:
- dodir /usr/share/p4est
- mv "${ED}"/usr/share/data "${ED}"/usr/share/p4est/data || die "mv failed"
- mv "${ED}"/etc/* "${ED}"/usr/share/p4est || die "mv failed"
- rmdir "${ED}"/etc/ || die "rmdir failed"
-}