summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-02 13:41:53 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-02 14:00:39 +0200
commita14ca5337d196857025c27a5d51832a225323e83 (patch)
tree73fecb59df8950ea9cb90007d4e43e9ae9b81e46 /sci-libs/libcifpp/libcifpp-1.1.1.ebuild
parentsci-chemistry/dssp: Take the package (diff)
downloadgentoo-a14ca5337d196857025c27a5d51832a225323e83.tar.gz
gentoo-a14ca5337d196857025c27a5d51832a225323e83.tar.bz2
gentoo-a14ca5337d196857025c27a5d51832a225323e83.zip
sci-libs/libcifpp: Bump to 1.1.1
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-libs/libcifpp/libcifpp-1.1.1.ebuild')
-rw-r--r--sci-libs/libcifpp/libcifpp-1.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/libcifpp/libcifpp-1.1.1.ebuild b/sci-libs/libcifpp/libcifpp-1.1.1.ebuild
new file mode 100644
index 000000000000..63a6e309a1b4
--- /dev/null
+++ b/sci-libs/libcifpp/libcifpp-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake tmpfiles
+
+DESCRIPTION="Code to work with mmCIF and PDB files"
+HOMEPAGE="https://github.com/PDB-REDO/libcifpp"
+SRC_URI="
+ https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ ftp://ftp.wwpdb.org/pub/pdb/data/monomers/components.cif.gz -> components-${PV}.cif.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+BDEPEND="
+ >=dev-libs/boost-1.70.0:0=[threads(+)]
+"
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ mkdir data || die
+ cp "${WORKDIR}"/components-${PV}.cif data/components.cif || die
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DUSE_RSRC=OFF
+ -DCIFPP_BUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}