summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-15 04:20:02 +0000
committerSam James <sam@gentoo.org>2024-03-15 04:20:42 +0000
commit3452a5d07e2f52b6d4a6a17316edde99ccc132cc (patch)
treec5636f73974173feb37b38b695d503abf6f4773a /sci-libs/lapack
parentapp-shells/fish: update LICENSE (diff)
downloadgentoo-3452a5d07e2f52b6d4a6a17316edde99ccc132cc.tar.gz
gentoo-3452a5d07e2f52b6d4a6a17316edde99ccc132cc.tar.bz2
gentoo-3452a5d07e2f52b6d4a6a17316edde99ccc132cc.zip
sci-libs/lapack: backport test summary fix
Closes: https://bugs.gentoo.org/924929 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/lapack')
-rw-r--r--sci-libs/lapack/files/lapack-3.12.0-test-summary.patch21
-rw-r--r--sci-libs/lapack/lapack-3.12.0-r1.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/lapack/files/lapack-3.12.0-test-summary.patch b/sci-libs/lapack/files/lapack-3.12.0-test-summary.patch
new file mode 100644
index 000000000000..1d2303cdb018
--- /dev/null
+++ b/sci-libs/lapack/files/lapack-3.12.0-test-summary.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/924929
+https://github.com/Reference-LAPACK/lapack/commit/a4298d5ff68047acfa44d6394ceb3a688a3b2534
+
+From 5b0687f429cf420629c0eeafba6a74a2564d4131 Mon Sep 17 00:00:00 2001
+From: Simon Maertens <simon@slmaertens.dev>
+Date: Fri, 1 Dec 2023 14:05:54 +0000
+Subject: [PATCH] Fixed search phrase for determining the amount of successful
+ tests
+
+--- a/lapack_testing.py
++++ b/lapack_testing.py
+@@ -136,7 +136,7 @@ def run_summary_test( f, cmdline, short_summary):
+ for line in pipe.readlines():
+ f.write(str(line))
+ words_in_line=line.split()
+- if (line.find("run")!=-1):
++ if (line.find("run)")!=-1):
+ # print line
+ whereisrun=words_in_line.index("run)")
+ nb_test_run+=int(words_in_line[whereisrun-2])
+
diff --git a/sci-libs/lapack/lapack-3.12.0-r1.ebuild b/sci-libs/lapack/lapack-3.12.0-r1.ebuild
index b1b9e9824637..743021f3426f 100644
--- a/sci-libs/lapack/lapack-3.12.0-r1.ebuild
+++ b/sci-libs/lapack/lapack-3.12.0-r1.ebuild
@@ -39,6 +39,7 @@ PATCHES=(
# https://github.com/Reference-LAPACK/lapack/issues/990#issuecomment-1973258284
# https://bugs.gentoo.org/878891
"${FILESDIR}"/lapack-3.12.0-correct-64bit-interface.patch
+ "${FILESDIR}"/lapack-3.12.0-test-summary.patch
)
pkg_setup() {