summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2022-06-01 10:04:04 +1200
committerMichael Orlitzky <mjo@gentoo.org>2022-06-02 07:53:46 -0400
commit88e4cecaa5ebd391e52c21035a2f44ddda61cca3 (patch)
treee0dd67b2ef20fadbd5e9864f5ff19f23ebd04487 /sci-libs/fplll
parentdev-python/botocore: remove unused patch (diff)
downloadgentoo-88e4cecaa5ebd391e52c21035a2f44ddda61cca3.tar.gz
gentoo-88e4cecaa5ebd391e52c21035a2f44ddda61cca3.tar.bz2
gentoo-88e4cecaa5ebd391e52c21035a2f44ddda61cca3.zip
sci-libs/fplll: upstream bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/25710 Closes: https://bugs.gentoo.org/848867 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/fplll')
-rw-r--r--sci-libs/fplll/Manifest1
-rw-r--r--sci-libs/fplll/fplll-5.4.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
index 2dc55c1776fe..8a8d858c9be9 100644
--- a/sci-libs/fplll/Manifest
+++ b/sci-libs/fplll/Manifest
@@ -1 +1,2 @@
DIST fplll-5.4.0.tar.gz 2612340 BLAKE2B 723230856461ac6418dad00e82fc7505dbbb7bfbbf68fa7f4f3240402d62f3e1ded3049c436a0f6aad9f020727d10acb3fe15dfb8b8a907f5b3c7b191e55e9a9 SHA512 a583aac73e4618ba240c28d3e8485cef6b9c184c11b33799404e96ab99502023073ed1c6fc0d3fbc4e6737415e9ea1a273f3f1e59ccba69d1546f56903567ebe
+DIST fplll-5.4.2.tar.gz 2618377 BLAKE2B e730c8646b9afb68515a23e533ea8ef833439d69f2130157bd6e38b1efab9116817535c261721c98b23410185271ffc323c687630e3ba262adb97fa5f69be787 SHA512 45324d89d0efeb269c1d1400332a51432e5d09f7bf0a6d651650e0941bb718493cbb66d65056b98691691236eaf348b2cae686ee06761f64380df98b6206c004
diff --git a/sci-libs/fplll/fplll-5.4.2.ebuild b/sci-libs/fplll/fplll-5.4.2.ebuild
new file mode 100644
index 000000000000..01b12f0488b4
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/7"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs qd"
+
+BDEPEND="qd? ( virtual/pkgconfig )"
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0
+ qd? ( sci-libs/qd )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with qd) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}