summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-11-19 17:05:51 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2022-11-19 17:58:24 +0100
commitbcaeda147edececb884f685eea7c1116e00b299d (patch)
treecde2b26a97c4582191c655a3da40c206a4f35c62 /sci-electronics
parentdev-python/xxhash: Remove old (diff)
downloadgentoo-bcaeda147edececb884f685eea7c1116e00b299d.tar.gz
gentoo-bcaeda147edececb884f685eea7c1116e00b299d.tar.bz2
gentoo-bcaeda147edececb884f685eea7c1116e00b299d.zip
sci-electronics/puff: Drop explicit linker format option
Fall back to using the default format options for LD as well as LLD. Furthermore add explicite LDPATH to locate libX11.so Closes: https://bugs.gentoo.org/831569 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/puff/files/puff-20181104-Makefile.patch5
-rw-r--r--sci-electronics/puff/puff-20181104.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/sci-electronics/puff/files/puff-20181104-Makefile.patch b/sci-electronics/puff/files/puff-20181104-Makefile.patch
index a874b9173aed..c51c87d1d33b 100644
--- a/sci-electronics/puff/files/puff-20181104-Makefile.patch
+++ b/sci-electronics/puff/files/puff-20181104-Makefile.patch
@@ -2,7 +2,7 @@
# respect CC and LD
--- Makefile.old 2021-07-03 16:34:49.937098627 +0200
+++ Makefile 2021-07-03 16:33:56.615284555 +0200
-@@ -1,12 +1,13 @@
+@@ -1,12 +1,14 @@
X11LIBDIR = /usr/X11R6/lib
PASCALCOMPILER = fpc
-CC = gcc
@@ -15,7 +15,8 @@
puff: $(POBJS) puff_c.o ppas.sh
- sed 's/link.res/link.res puff_c.o -lX11/' <ppas.sh >ppasx.sh
+ sed -i -e 's!^[^[:space:]]\+ -b!$(LD) -b!g' ppas.sh
-+ sed 's/.res/.res $(LDFLAGS) puff_c.o -lX11/' <ppas.sh >ppasx.sh
++ sed -i -e 's/\-b [^[:space:]]\+//g' ppas.sh
++ sed 's:.res:.res $(LDFLAGS) puff_c.o -lX11:' <ppas.sh >ppasx.sh
sh ppasx.sh
%.o: %.pas
diff --git a/sci-electronics/puff/puff-20181104.ebuild b/sci-electronics/puff/puff-20181104.ebuild
index 3ec8bccda1fa..ab384b49ccc0 100644
--- a/sci-electronics/puff/puff-20181104.ebuild
+++ b/sci-electronics/puff/puff-20181104.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,7 +21,10 @@ src_prepare() {
default
# fix lib path for X11 and dont ignore LDFLAGS
# respect CC and LD
+ # additional drop explicite format option for linker (bug #831569)
eapply -p0 "${FILESDIR}"/$P-Makefile.patch
+ # add missing LDPATH for libX11.so
+ sed -i -e "s:-lX11:-L/usr/$(get_libdir) -lX11:g" Makefile || die
eapply_user
}