summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2022-06-07 11:56:52 +0800
committerSam James <sam@gentoo.org>2022-06-16 17:34:42 +0100
commit581be46a04d856431563a529466bb5792a5df486 (patch)
treed6d358b302ab3b25afdcadf277093ceaaec59169 /sci-electronics
parentdev-python/pyroute2: update maintainers (diff)
downloadgentoo-581be46a04d856431563a529466bb5792a5df486.tar.gz
gentoo-581be46a04d856431563a529466bb5792a5df486.tar.bz2
gentoo-581be46a04d856431563a529466bb5792a5df486.zip
sci-electronics/systemc: fix bug 849917 and QA report
Keyword 2.3.4-r2 for ~riscv Fix toolchain-funcs: indirect inherit usage: 'tc-getCXX', line 37 Fix HOMEPAGE: permanently redirected: https://accellera.org/community/systemc -> https://systemc.org update EAPI 7 -> 8, and dropped unused test use flag Closes: https://bugs.gentoo.org/849917 Signed-off-by: Huang Rui <vowstar@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25783 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/systemc/systemc-2.3.4-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-electronics/systemc/systemc-2.3.4-r2.ebuild b/sci-electronics/systemc/systemc-2.3.4-r2.ebuild
new file mode 100644
index 000000000000..9e61f04f5519
--- /dev/null
+++ b/sci-electronics/systemc/systemc-2.3.4-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV}_pub_rev_20190614"
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
+HOMEPAGE="
+ https://systemc.org
+ https://github.com/accellera-official/systemc
+"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/accellera-official/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/accellera-official/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="debug doc examples static-libs"
+REQUIRED_USE="examples? ( doc )"
+
+src_prepare() {
+ default
+ eautoconf --force
+}
+
+src_configure() {
+ econf CXX="$(tc-getCXX)" \
+ $(use_enable debug) \
+ $(use_enable static-libs static) \
+ --with-unix-layout
+}
+
+src_install() {
+ default
+ if use doc; then
+ if use examples; then
+ docompress -x /usr/share/doc/"${PF}"/examples
+ else
+ rm -r "${ED}"/usr/share/doc/"${PF}"/examples || die
+ fi
+ else
+ rm -r "${ED}"/usr/share/doc/"${PF}" || die
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
+}