summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/unafold
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/unafold')
-rw-r--r--sci-biology/unafold/Manifest1
-rw-r--r--sci-biology/unafold/metadata.xml5
-rw-r--r--sci-biology/unafold/unafold-3.8-r1.ebuild28
-rw-r--r--sci-biology/unafold/unafold-3.8.ebuild32
4 files changed, 66 insertions, 0 deletions
diff --git a/sci-biology/unafold/Manifest b/sci-biology/unafold/Manifest
new file mode 100644
index 000000000000..c9d5717af552
--- /dev/null
+++ b/sci-biology/unafold/Manifest
@@ -0,0 +1 @@
+DIST unafold-3.8.tar.bz2 282418 SHA256 7552724ce82ad8618167ec0524d8c931ac4383314669322c8424cafc06c2bf38 SHA512 4c83cf0122e4d4ec2b713833adb11eb608b0f880f5b68114aefd8c7fa980c8d02f9a6cfc0c88cd640b4457e65954b05189118e8ac5ed207b2f9910738ca71a6c WHIRLPOOL 9fd5744e66d8669817433b5427fc671ac5185760ffaf0682a7938fc5542f24cbe7b08f7722c7135cd3197af2d748740e0ca35a70a5f6c40a4a5d5aaa806ed923
diff --git a/sci-biology/unafold/metadata.xml b/sci-biology/unafold/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/unafold/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/unafold/unafold-3.8-r1.ebuild b/sci-biology/unafold/unafold-3.8-r1.ebuild
new file mode 100644
index 000000000000..f47f9d02ab36
--- /dev/null
+++ b/sci-biology/unafold/unafold-3.8-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="Unified Nucleic Acid Folding and hybridization package"
+HOMEPAGE="http://mfold.rna.albany.edu/"
+SRC_URI="http://dinamelt.bioinfo.rpi.edu/download/${P}.tar.bz2"
+
+LICENSE="unafold"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="custom-cflags"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # recommended in README
+ use custom-cflags || append-flags -O3
+
+ sed \
+ -e 's:hybrid (UNAFold) 3.7:hybrid (UNAFold) 3.8:g' \
+ -i tests/hybrid.tml || die
+}
diff --git a/sci-biology/unafold/unafold-3.8.ebuild b/sci-biology/unafold/unafold-3.8.ebuild
new file mode 100644
index 000000000000..5d258f941645
--- /dev/null
+++ b/sci-biology/unafold/unafold-3.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit flag-o-matic
+
+DESCRIPTION="Unified Nucleic Acid Folding and hybridization package"
+HOMEPAGE="http://mfold.rna.albany.edu/"
+SRC_URI="http://dinamelt.bioinfo.rpi.edu/download/${P}.tar.bz2"
+
+LICENSE="unafold"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # recommended in README
+ append-flags -O3
+
+ sed \
+ -e 's:hybrid (UNAFold) 3.7:hybrid (UNAFold) 3.8:g' \
+ -i tests/hybrid.tml || die
+}
+
+src_install() {
+ einstall || die
+}